<!DOCTYPE html>
<html prefix="og: http://ogp.me/ns#">
<head>
<script src="/cdn-cgi/apps/head/xCynX04EXBjm7zpzyubjSaR18uA.js"></script><script data-minify="1" data-mrf-script="garda" data-mrf-dt="1" data-mrf-host="live.mrf.io" data-mrf-ct="section" src="https://eurweb.com/wp-content/cache/min/1/statics/marfeel/gardac-sync-91d19d98183fd51625063855fdf39456.js" data-cfasync="false"></script>



<script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2nkuHDAyW9zze5_amYWGdGF1QtBw4LE6zB80Kh6vBr7RtspHz4Yr0UhAA-BcYAw4",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;!(function(i,a,t,e){var n=a[t];function c(a){if(a&&a.data){var e,t="__tcfapiCall",c="string"==typeof a.data&&0<=a.data.indexOf(t);(e=c?((function i(t){try{return JSON.parse(t)}catch(n){}})(a.data)||{})[t]:(a.data||{})[t])&&n(e.command,e.version,function(t,n){var i={__tcfapiReturn:{returnValue:t,success:n,callId:e.callId}};a.source.postMessage(c?JSON.stringify(i):i,"*")},e.parameter)}}!(function o(){if(!window.frames[e]){var t=i.body;if(t){var n=i.createElement("iframe");n.style.display="none",n.name=e,t.appendChild(n)}else setTimeout(o,5)}})(),"function"!=typeof n&&(n=a[t]=a[t]||function f(){for(var t=[],n=[],i=0;i<arguments.length;i++)n.push(arguments[i]);if(!n.length)return t;"ping"===n[0]?n[2]({gdprAppliesGlobally:!!a.__cmpGdprAppliesGlobally,cmpLoaded:!1,cmpStatus:"stub"}):0<n.length&&t.push(n)},a.addEventListener?a.addEventListener("message",c,!1):a.attachEvent&&a.attachEvent("onmessage",c))})(document,window,"__tcfapi","__tcfapiLocator");</script>
<meta name="viewport" content="width=device-width">
<script type="text/javascript"> var googletag = googletag || {}; googletag.cmd = googletag.cmd || []; var pbjs = pbjs || {}; pbjs.que = pbjs.que || []; </script>
<script data-minify="1" async="" src="https://eurweb.com/wp-content/cache/min/1/d2ehZtyVAa1kXxOtMxFp7XciXcU/gpt_and_prebid/config-1fd0b39ee7d6d1ff004f814abf9845f2.js"></script>
<script async src='https://tag.simpli.fi/sifitag/04a3ef20-beff-0138-327c-06abc14c0bc6'></script>
<meta charset="UTF-8">
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="pingback" href="https://eurweb.com/xmlrpc.php" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?resize=650%2C286&#038;ssl=1" />
<meta name="twitter:image" content="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?resize=650%2C286&#038;ssl=1" />
<meta property="og:url" content="https://eurweb.com/2020/10/21/865561/" />
<meta property="og:title" content="Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria" />
<meta property="og:description" content="PHILADELPHIA, Pa. — Nationally renowned civil rights and personal injury attorney Ben Crump released the following statement in response to Nigerian security forces opening fire on peaceful protestors last night in Lagos, Nigeria: “It is unacceptable for a government to brutalize and murder its own people. We are calling for transparency and accountability from the [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://eurweb.com/2020/10/21/865561/">
<meta name="twitter:title" content="Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria">
<meta name="twitter:description" content="PHILADELPHIA, Pa. — Nationally renowned civil rights and personal injury attorney Ben Crump released the following statement in response to Nigerian security forces opening fire on peaceful protestors last night in Lagos, Nigeria: “It is unacceptable for a government to brutalize and murder its own people. We are calling for transparency and accountability from the [&hellip;]">
<title>Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria &#8211; EURweb</title><link rel="stylesheet" href="https://eurweb.com/wp-content/cache/min/1/223aba09ccb9a3271163d2944b44b421.css" media="all" data-minify="1" />
<link rel='dns-prefetch' href='//public.tockify.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="EURweb &raquo; Feed" href="https://eurweb.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="EURweb &raquo; Comments Feed" href="https://eurweb.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="EURweb &raquo; Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria Comments Feed" href="https://eurweb.com/2020/10/21/865561/feed/" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='mvp-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='fontawesome-child-css' href='https://eurweb.com/wp-content/themes/zox-news-child/font-awesome/css/font-awesome.css?ver=5.4.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mvp-fonts-css' href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%2C700%2C900%7COswald%3A400%2C700%7CAdvent+Pro%3A700%7COpen+Sans%3A700%7CAnton%3A400Calistoga%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CCalistoga%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CCalistoga%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7Cmontserrat%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7Cmontserrat%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CCalistoga%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;display=swap' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery.js'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/c/5.4.2/wp-includes/js/jquery/jquery-migrate.min-052e5114d8ba03f7039b2e2e579e510c.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/p/jetpack/8.9.1/_inc/build/related-posts/related-posts.min-328a0695ca6380969d02972ff24668bf.js'></script>
<script type='text/javascript' src='https://eurweb.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://eurweb.com/wp-json/' />
<link rel='prev' title='Shonda Rhimes Says Clash Over Disneyland Ticket Lead to ABC Exit: &#8216;I Felt Like I Was Dying&#8217;' href='https://eurweb.com/2020/10/21/shonda-rhimes-says-clash-over-disneyland-ticket-lead-to-abc-exit-i-felt-like-i-was-dying/' />
<link rel='next' title='Tia Mowry Reveals That She And Husband Cory Hardrict Schedule Sex' href='https://eurweb.com/2020/10/21/tia-mowry-reveals-that-she-and-husband-cory-hardrict-schedule-sex/' />
<link rel="canonical" href="https://eurweb.com/2020/10/21/865561/" />
<link rel="alternate" type="application/json+oembed" href="https://eurweb.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feurweb.com%2F2020%2F10%2F21%2F865561%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://eurweb.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Feurweb.com%2F2020%2F10%2F21%2F865561%2F&#038;format=xml" />
<link rel="alternate" media="only screen and (max-width: 640px)" href="https://mobile.eurweb.com/2020/10/21/865561/?q=/2020/10/21/865561/&">

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-26066171-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-26066171-1');
</script>
<meta name="twitter:card" content="summary"></meta>
<script>
!function(w,d){
    var adpushup = w.adpushup = w.adpushup || {que:[]};
    adpushup.que.push(function(){
        adpushup.init();
    })
}(window, document);
</script>

<meta property="og:site_name" content="EURweb" />
<meta property="og:locale" content="en_us" />
<meta property="og:type" content="article" />
<meta property="og:image:width" content="650" />
<meta property="og:image:height" content="286" />
<meta property="og:image" content="https://eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg" />
<meta property="og:title" content="Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria" />
<meta property="og:url" content="https://eurweb.com/2020/10/21/865561/" />
<meta property="og:description" content="PHILADELPHIA, Pa. — Nationally renowned civil rights and personal injury attorney Ben Crump released the following statement in response to Nigerian security forces opening fire on peaceful protestors last night in Lagos, Nigeria: “It is unacceptable for a government to brutalize and murder its own people. We are calling for transparency and accountability from the [&hellip;]" />

<meta property="fb:pages" content="45752458150" /><link rel="amphtml" href="https://eurweb.com/2020/10/21/865561/amp/"><style type='text/css'>img#wpstats{display:none}</style><meta name="description" content="“The ability for citizens to demonstrate safely when they see injustice within their government should be a sacred right across the globe.&quot; - Ben Crump">
<meta property="og:title" content="Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria &#8211; EURweb">
<meta property="og:type" content="article">
<meta property="og:image" content="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?fit=650%2C286&amp;ssl=1">
<meta property="og:image:width" content="650">
<meta property="og:image:height" content="286">
<meta property="og:description" content="“The ability for citizens to demonstrate safely when they see injustice within their government should be a sacred right across the globe.&quot; - Ben Crump">
<meta property="og:url" content="https://eurweb.com/2020/10/21/865561/">
<meta property="og:locale" content="en_US">
<meta property="og:site_name" content="EURweb">
<meta property="article:published_time" content="2020-10-22T01:03:15+00:00">
<meta property="article:modified_time" content="2020-10-22T01:27:48+00:00">
<meta property="og:updated_time" content="2020-10-22T01:27:48+00:00">
<meta property="article:section" content="#BlackLivesMatter">
<meta property="article:tag" content="ben crump">
<meta property="article:tag" content="nigeria anti-police brutality protest">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?fit=650%2C286&#038;ssl=1">
<link rel="amphtml" href="https://eurweb.com/2020/10/21/865561/amp/"><link rel="icon" href="https://eurweb.com/wp-content/uploads/2020/04/favicon.ico" sizes="32x32" />
<link rel="icon" href="https://eurweb.com/wp-content/uploads/2020/04/favicon.ico" sizes="192x192" />
<link rel="apple-touch-icon" href="https://eurweb.com/wp-content/uploads/2020/04/favicon.ico" />
<meta name="msapplication-TileImage" content="https://eurweb.com/wp-content/uploads/2020/04/favicon.ico" />

<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-26066171-1']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	<!-- Global site tag (gtag.js) - Google Analytics -->

  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-26066171-1');
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://eurweb.com/?custom-css=2911106cfa" />
<script data-cfasync="false" type="text/javascript">(function(w, d) { var s = d.createElement('script'); s.src = '//cdn.adpushup.com/41485/adpushup.js'; s.type = 'text/javascript'; s.async = true; (d.getElementsByTagName('head')[0] || d.getElementsByTagName('body')[0]).appendChild(s); })(window, document);</script>
<script defer src="https://users.api.jeeng.com/users/domains/2OjlBNmlRA/sdk/configs"> </script>
<script data-minify="1" defer src="https://eurweb.com/wp-content/cache/min/1/v3-32700f4dab91039e6bb0e50a05aec5c1.js"> </script>

<script src="/cdn-cgi/apps/head/xCynX04EXBjm7zpzyubjSaR18uA.js"></script><script>
    (function(h,o,t,j,a,r){
        h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
        h._hjSettings={hjid:560598,hjsv:5};
        a=o.getElementsByTagName('head')[0];
        r=o.createElement('script');r.async=1;
        r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
        a.appendChild(r);
    })(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');
</script>

<style>ul.mvp-feat1-list-buts{
	text-align:left!important;
	}
	ul.mvp-feat1-list-buts li:last-child{
	margin-left:-7px !Important;
	}
	</style>
</head>
<body class="post-template-default single single-post postid-865561 single-format-standard ">
<div id="mvp-fly-wrap">
<div id="mvp-fly-menu-top" class="left relative">
<div class="mvp-fly-top-out left relative">
<div class="mvp-fly-top-in">
<div id="mvp-fly-logo" class="left relative">
<a href="https://eurweb.com/"><img src="https://eurweb.com/wp-content/uploads/2020/03/eurWeb-logo-final.png" alt="EURweb" data-rjs="2" /></a>
</div>
</div>
<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
</div>
<div id="mvp-fly-menu-wrap">
<nav class="mvp-fly-nav-menu left relative">
<div class="menu-category-navigation-container"><ul id="menu-category-navigation" class="menu"><li id="menu-item-850556" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-850556"><a href="https://www.eurweb.com">HOME</a></li>
<li id="menu-item-129593" class="menu-item menu-item-type- menu-item-object- menu-item-has-children menu-item-129593"><a>NEWS</a>
<ul class="sub-menu">
<li id="menu-item-829227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829227"><a href="https://eurweb.com/category/news-2/headlines/">Top News</a></li>
<li id="menu-item-829228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829228"><a href="https://eurweb.com/category/news-2/black-celebrity-gossip-gossip/">Black Celebrity Gossip</a></li>
<li id="menu-item-829229" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829229"><a href="https://eurweb.com/category/news-2/obamapolitical/">Obama/Trump/Political</a></li>
<li id="menu-item-829230" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829230"><a href="https://eurweb.com/category/living-2/relationships/sex-erotica/">Sex &#8211; Erotica</a></li>
<li id="menu-item-829231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829231"><a href="https://eurweb.com/category/news-2/othernews/">Other News</a></li>
<li id="menu-item-829232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829232"><a href="https://eurweb.com/category/eurthisnthatcom/">ThisNThat</a></li>
<li id="menu-item-829233" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829233"><a href="https://eurweb.com/category/pressrelease/">Press Release</a></li>
</ul>
</li>
<li id="menu-item-129597" class="menu-item menu-item-type- menu-item-object- menu-item-129597"><a>SHOP</a></li>
<li id="menu-item-828069" class="menu-item menu-item-type- menu-item-object- menu-item-has-children menu-item-828069"><a>ORIGINAL CONTENT</a>
<ul class="sub-menu">
<li id="menu-item-829234" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829234"><a href="https://eurweb.com/category/weeklycolumns/">Columns</a></li>
<li id="menu-item-829235" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829235"><a href="https://eurweb.com/category/weeklycolumns/steven-ivory/">Steven Ivory</a></li>
<li id="menu-item-829237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829237"><a href="https://eurweb.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-829236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829236"><a href="https://eurweb.com/category/promotions/">Promotions</a></li>
<li id="menu-item-829238" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829238"><a href="https://eurweb.com/category/entertainment/television/">Television</a></li>
<li id="menu-item-829239" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829239"><a href="https://eurweb.com/category/entertainment/sports/">Sports</a></li>
<li id="menu-item-829240" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829240"><a href="https://eurweb.com/category/entertainment/music/">Music</a></li>
<li id="menu-item-829241" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829241"><a href="https://eurweb.com/category/entertainment/radio/">Radio</a></li>
<li id="menu-item-829242" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829242"><a href="https://eurweb.com/category/entertainment/film/">Film</a></li>
<li id="menu-item-829243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829243"><a href="https://eurweb.com/category/entertainment/books/">Books</a></li>
<li id="menu-item-829244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829244"><a href="https://eurweb.com/category/entertainment/humorcomedy/">Humor/Comedy</a></li>
<li id="menu-item-829245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829245"><a href="https://eurweb.com/category/entertainment/theater/">Theater</a></li>
</ul>
</li>
<li id="menu-item-129595" class="menu-item menu-item-type- menu-item-object- menu-item-has-children menu-item-129595"><a>LIVING</a>
<ul class="sub-menu">
<li id="menu-item-829250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829250"><a href="https://eurweb.com/category/living-2/business-2/">Business</a></li>
<li id="menu-item-829338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829338"><a href="https://eurweb.com/category/entertainment/gospel/">Gospel</a></li>
<li id="menu-item-829251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829251"><a href="https://eurweb.com/category/living-2/business-2/real-estate/">Real Estate</a></li>
<li id="menu-item-829252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829252"><a href="https://eurweb.com/category/living-2/health/">Health</a></li>
<li id="menu-item-829253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829253"><a href="https://eurweb.com/category/living-2/relationships/">Relationships</a></li>
<li id="menu-item-829254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829254"><a href="https://eurweb.com/category/living-2/spirituality/">Spirituality</a></li>
</ul>
</li>
<li id="menu-item-129596" class="menu-item menu-item-type- menu-item-object- menu-item-has-children menu-item-129596"><a>MULTIMEDIA</a>
<ul class="sub-menu">
<li id="menu-item-829255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829255"><a href="https://eurweb.com/category/multimedia/audio-multimedia/">Audio</a></li>
<li id="menu-item-829256" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829256"><a href="https://eurweb.com/category/multimedia/photos-multimedia/">Photos</a></li>
<li id="menu-item-829257" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829257"><a href="https://eurweb.com/category/multimedia/photosvideos/">Photos/Videos/Audio</a></li>
</ul>
</li>
<li id="menu-item-829220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829220"><a href="https://eurweb.com/category/events/">EVENTS</a></li>
<li id="menu-item-829218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829218"><a href="https://eurweb.com/category/education/">EDUCATION</a></li>
<li id="menu-item-829221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-829221"><a href="https://eurweb.com/category/news-2/tech/">TECH</a></li>
<li id="menu-item-829222" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-829222"><a href="https://eurweb.com/about-usmedia-kit/">ABOUT US</a></li>
<li id="menu-item-829223" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-829223"><a href="https://eurweb.com/advertise-with-us/">ADVERTISE WITH US</a></li>
<li id="menu-item-829224" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-829224"><a href="https://eurweb.com/links/">LINKS</a></li>
<li id="menu-item-829225" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-829225"><a href="https://eurweb.com/sitemap/">SITEMAP</a></li>
<li id="menu-item-829226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-829226"><a href="https://eurweb.com/contact-eurweb/">CONTACT US</a></li>
</ul></div> </nav>
</div>
<div id="mvp-fly-soc-wrap">
<span class="mvp-fly-soc-head">Connect with us</span>
<ul class="mvp-fly-soc-list left relative">
<li><a href="https://www.facebook.com/EURweb/" target="_blank" class="fa fa-facebook fa-2"></a></li>
<li><a href="https://twitter.com/eurweb" target="_blank" class="fa fa-twitter fa-2"></a></li>
<li><a href="https://www.instagram.com/eurweb" target="_blank" class="fa fa-instagram fa-2"></a></li>
</ul>
</div>
</div> <div id="mvp-site" class="left relative">
<div id="mvp-search-wrap">
<div id="mvp-search-box">
<form method="get" id="searchform" action="https://eurweb.com/">
<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
<input type="hidden" id="searchsubmit" value="Search" />
</form> </div>
<div class="mvp-search-but-wrap mvp-search-click">
<span></span>
<span></span>
</div>
</div>
<div id="mvp-site-wall" class="left relative">
<div id="mvp-site-main" class="left relative">
<header id="mvp-main-head-wrap" class="left relative">
<nav id="mvp-main-nav-wrap" class="left relative">
<div id="mvp-main-nav-top" class="left relative">
<div class="mvp-main-box">
<div id="mvp-nav-top-wrap" class="left relative">
<div class="mvp-nav-top-right-out left relative">
<div class="mvp-nav-top-right-in">
<div class="mvp-nav-top-cont left relative">
<div class="mvp-nav-top-left-out relative">
<div class="mvp-nav-top-left">
<div class="mvp-nav-soc-wrap">
<a href="https://www.facebook.com/EURweb/" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook fa-2"></span></a>
<a href="https://twitter.com/eurweb" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
<a href="https://www.instagram.com/eurweb" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a>
</div>
<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div class="mvp-nav-top-left-in">
<div class="mvp-nav-top-mid left relative" itemscope itemtype="http://schema.org/Organization">
<a class="mvp-nav-logo-reg" itemprop="url" href="https://eurweb.com/"><img itemprop="logo" src="https://eurweb.com/wp-content/uploads/2020/03/eurWeb-logo-final.png" alt="EURweb" data-rjs="2" /></a>
<a class="mvp-nav-logo-small" href="https://eurweb.com/"><img src="https://eurweb.com/wp-content/uploads/2020/03/eurWeb-logo-final.png" alt="EURweb" data-rjs="2" /></a>
<h2 class="mvp-logo-title">EURweb</h2>
<div class="mvp-drop-nav-title left">
<h4>Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria</h4>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="mvp-nav-top-right">
<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
</div>
</div>
</div>
</div>
</div>
<div id="mvp-main-nav-bot" class="left relative">
<div id="mvp-main-nav-bot-cont" class="left">
<div class="mvp-main-box">
<div id="mvp-nav-bot-wrap" class="left">
<div class="mvp-nav-bot-right-out left">
<div class="mvp-nav-bot-right-in">
<div class="mvp-nav-bot-cont left">
<div class="mvp-nav-bot-left-out">
<div class="mvp-nav-bot-left left relative">
<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div class="mvp-nav-bot-left-in">
<div class="mvp-nav-menu left">
<div class="menu-new-menu-for-new-site-container"><ul id="menu-new-menu-for-new-site" class="menu"><li id="menu-item-828458" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-828458"><a href="https://eurweb.com/category/news-2/">News+</a></li>
<li id="menu-item-828460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-828460"><a href="https://eurweb.com/category/news-2/black-celebrity-gossip-gossip/">Gossip</a></li>
<li id="menu-item-828461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-828461"><a href="https://eurweb.com/category/radioscope-oldschool/">RadioScope-OldSchool</a></li>
<li id="menu-item-828463" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-828463"><a href="#">Events-Calendar</a></li>
<li id="menu-item-828462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-828462"><a href="https://eurweb.com/category/featuredarticles/">Features</a></li>
<li id="menu-item-861785" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-861785"><a href="https://eurweb.com/category/podcasts/">Podcasts</a></li>
<li id="menu-item-827238" class="menu-item menu-item-type- menu-item-object- menu-item-827238"><a>TV Calendar</a></li>
</ul></div>
</div>
</div>
</div>
</div>
</div>
<div class="mvp-nav-bot-right left relative">
<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
</div>
</div>
</div>
</div>
</div>
</div>
</nav>
</header>
<div id="mvp-main-body-wrap" class="left relative">
<iframe width="100%" height="40" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" src="https://eurweb.whatsopensolution.com/ticker/"></iframe> <article id="mvp-article-wrap" itemscope itemtype="http://schema.org/NewsArticle">
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://eurweb.com/2020/10/21/865561/" />
<div id="mvp-article-cont" class="left relative">
<div class="mvp-main-box">
<div id="mvp-post-main" class="left relative">
<header id="mvp-post-head" class="left relative">
<h3 class="mvp-post-cat left relative"> <a class="mvp-post-cat-link" href="https://eurweb.com/category/news-2/blacklivesmatter/">
<span class="mvp-post-cat left"> #BlackLivesMatter</span></a> </h3>
<h1 class="mvp-post-title left entry-title" itemprop="headline">Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria</h1>
<div class="mvp-author-info-wrap left relative">
<div class="mvp-author-info-thumb left relative">
<img alt='' src='https://secure.gravatar.com/avatar/75d389737dd4bc2e54cf0d5fcc866431?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/75d389737dd4bc2e54cf0d5fcc866431?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /> </div>
<div class="mvp-author-info-text left relative">
<div class="mvp-author-info-date left relative">
<p>Published</p> <span class="mvp-post-date">2 hours ago</span> <p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-10-21">October 21, 2020</time></span>
<meta itemprop="dateModified" content="2020-10-21" />
</div>
<div class="mvp-author-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://eurweb.com/author/rabercom/" title="Posts by Fisher Jack" rel="author">Fisher Jack</a></span> </div>
</div>
</div>
</header>
<div class="mvp-post-main-out left relative">
<div class="mvp-post-main-in">
<div id="mvp-post-content" class="left relative">
<div id="mvp-post-feat-img" class="left relative mvp-post-feat-img-wide2" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<img width="650" height="286" src="https://eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg" class="attachment- size- wp-post-image" alt="Nigeria anti-police protests" srcset="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?w=650&amp;ssl=1 650w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?resize=300%2C132&amp;ssl=1 300w" sizes="(max-width: 650px) 100vw, 650px" data-attachment-id="865562" data-permalink="https://eurweb.com/2020/10/21/865561/nigeria-anti-police-protests/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?fit=650%2C286&amp;ssl=1" data-orig-size="650,286" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Nigeria anti-police protests" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?fit=300%2C132&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?fit=650%2C286&amp;ssl=1" /> <meta itemprop="url" content="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?resize=650%2C286&#038;ssl=1">
<meta itemprop="width" content="650">
<meta itemprop="height" content="286">
</div>
<div id="mvp-content-wrap" class="left relative">
<div class="mvp-post-soc-out right relative">
<div class="mvp-post-soc-wrap left relative">
<ul class="mvp-post-soc-list left relative">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://eurweb.com/2020/10/21/865561/&amp;t=Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="mvp-post-soc-fb">
<i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
</li>
</a>
<a href="#" onclick="window.open('http://twitter.com/share?text=Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria -&amp;url=https://eurweb.com/2020/10/21/865561/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="mvp-post-soc-twit">
<i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
</li>
</a>
<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://eurweb.com/2020/10/21/865561/&amp;media=https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?resize=650%2C286&#038;ssl=1&amp;description=Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="mvp-post-soc-pin">
<i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#98a7ebedfaf2fdfbeca5d9ececf7eaf6fde1b8dafdf6b8dbeaedf5e8b8d1ebebedfdebb8cbecf9ecfdf5fdf6ecb8d9faf7edecb8c8f7f4f1fbfdb8cef1f7f4fdf6fbfdb8d9fff9f1f6ebecb8c8eaf7ecfdebecf7eaebb8f1f6b8d4f9fff7ebb8d6f1fffdeaf1f9bef9f5e8a3dad7dcc1a5d1b8fef7edf6fcb8ecf0f1ebb8f9eaecf1fbf4fdb8f1f6ecfdeafdebecf1f6ffb8f9f6fcb8ecf0f7edfff0ecb8f7feb8ebf0f9eaf1f6ffb8f1ecb8eff1ecf0b8e1f7edb6b8dbf0fdfbf3b8f1ecb8f7edeca2b8f0ecece8eba2b7b7fdedeaeffdfab6fbf7f5b7aaa8aaa8b7a9a8b7aaa9b7a0aeadadaea9b7">
<li class="mvp-post-soc-email">
<i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
</li>
</a>
<a href="https://eurweb.com/2020/10/21/865561/#respond">
<li class="mvp-post-soc-com mvp-com-click">
<i class="fa fa-2 fa-commenting" aria-hidden="true"></i>
</li>
</a>
</ul>
</div>
<div id="mvp-soc-mob-wrap">
<div class="mvp-soc-mob-out left relative">
<div class="mvp-soc-mob-in">
<div class="mvp-soc-mob-left left relative">
<ul class="mvp-soc-mob-list left relative">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://eurweb.com/2020/10/21/865561/&amp;t=Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="mvp-soc-mob-fb">
<i class="fa fa-facebook" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Share</span>
</li>
</a>
<a href="#" onclick="window.open('http://twitter.com/share?text=Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria -&amp;url=https://eurweb.com/2020/10/21/865561/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="mvp-soc-mob-twit">
<i class="fa fa-twitter" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Tweet</span>
</li>
</a>
<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://eurweb.com/2020/10/21/865561/&amp;media=https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?resize=650%2C286&#038;ssl=1&amp;description=Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="mvp-soc-mob-pin">
<i class="fa fa-pinterest-p" aria-hidden="true"></i>
</li>
 </a>
<a href="whatsapp://send?text=Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria https://eurweb.com/2020/10/21/865561/"><div class="whatsapp-share"><span class="whatsapp-but1">
<li class="mvp-soc-mob-what">
<i class="fa fa-whatsapp" aria-hidden="true"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#26195553444c4345521b675252495448435f06644348066554534b56066f55555343550675524752434b4348520667444953520676494a4f454306704f494a43484543066741474f4855520676544952435552495455064f48066a4741495506684f4143544f4700474b561d6469627f1b6f06404953484206524e4f55064754524f454a43064f485243544355524f48410647484206524e4953414e5206494006554e47544f4841064f5206514f524e065f49530806654e43454d064f52064953521c064e525256551c09094353545143440845494b0914161416091716091417091e101313101709">
<li class="mvp-soc-mob-email">
<i class="fa fa-envelope-o" aria-hidden="true"></i>
</li>
</a>
<a href="https://eurweb.com/2020/10/21/865561/#respond">
<li class="mvp-soc-mob-com mvp-com-click">
<i class="fa fa-comment-o" aria-hidden="true"></i>
</li>
</a>
</ul>
</div>
</div>
<div class="mvp-soc-mob-right left relative">
<i class="fa fa-ellipsis-h" aria-hidden="true"></i>
</div>
</div>
</div>
<div class="mvp-post-soc-in">
<div id="mvp-content-body" class="left relative">
<div id="mvp-content-body-top" class="left relative">
<div id="mvp-content-main" class="left relative">
<p><iframe src="https://www.youtube.com/embed/6ckz1kyeU-E" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<p><strong>PHILADELPHIA, Pa.</strong> — Nationally renowned civil rights and personal injury attorney Ben Crump released the following statement in response to Nigerian security forces <a href="http://email2.sachsmedia.com/c/eJwdjsGKxCAQRL8muU2w1Wg8eMiwk-P-Q0fbiZCMg7qE-fs1AwVVNEXX81aCBh76aDnjDBgHzoUCPcAw_8jFPADuywO0mpdOsoJuKwf5iINLR79ZJ41h3jmjhWPoV0PcMTUxUASGRuh3u9X6Lp2YO740nec5vD41HlSuF-1y7TYD9s1XJeXdN8eQo8MWfuOTcsTbO6dKpZZb2VKq8fUctnrsfbYZV8orxp0-DZL-8knrF7BaEhDQ-wkkU4BKQCPWCpyRwKURY6uYUQOZMAo9wegdkzT5acUQOAYFFP4BPmlWxg" target="_blank" rel="noopener noreferrer">opening fire</a> on peaceful protestors last night in Lagos, Nigeria:</p>
<p><em>“It is unacceptable for a government to brutalize and murder its own people. We are calling for transparency and accountability from the Lagos government on the cruel and unnecessary violence used against these peaceful protestors.</em></p>
<p><em>“The ability for citizens to demonstrate safely when they see injustice within their government should be a sacred right across the globe. When our brothers and sisters abroad cannot speak out without fearing for their lives, it is clear we are dealing with an international human rights violation that demands we raise our voices.”</em></p>
<p><strong>MORE NEWS: <a href="https://eurweb.com/2020/10/21/dr-jennifer-satterfield-siegel-its-very-rewarding-being-an-african-american-nascar-team-owner/" target="_blank" rel="noopener noreferrer">Dr. Jennifer Satterfield-Siegel: It’s ‘Very Rewarding’ Being An African American NASCAR Team Owner</a></strong></p>
<div id="attachment_730628" style="width: 470px" class="wp-caption aligncenter"><a href="https://i2.wp.com/eurweb.com/wp-content/uploads/2018/06/Benjamin-Crump2.jpg?ssl=1"><img aria-describedby="caption-attachment-730628" data-attachment-id="730628" data-permalink="https://eurweb.com/2018/06/04/evidence-of-innocence-host-benjamin-crump-on-mass-incarceration-being-an-extension-of-slavery-eur-exclusive/benjamin-crump2/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2018/06/Benjamin-Crump2.jpg?fit=460%2C254&amp;ssl=1" data-orig-size="460,254" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Benjamin Crump" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2018/06/Benjamin-Crump2.jpg?fit=300%2C166&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2018/06/Benjamin-Crump2.jpg?fit=460%2C254&amp;ssl=1" class="size-full wp-image-730628" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2018/06/Benjamin-Crump2.jpg?resize=460%2C254&#038;ssl=1" alt="Benjamin Crump" width="460" height="254" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2018/06/Benjamin-Crump2.jpg?w=460&amp;ssl=1 460w, https://i2.wp.com/eurweb.com/wp-content/uploads/2018/06/Benjamin-Crump2.jpg?resize=300%2C166&amp;ssl=1 300w" sizes="(max-width: 460px) 100vw, 460px" data-recalc-dims="1" /></a><p id="caption-attachment-730628" class="wp-caption-text">Benjamin Crump</p></div>
<p><strong>ABOUT BEN CRUMP LAW</strong></p>
<p>Through his work, nationally renowned civil rights and personal injury attorney Ben Crump has spearheaded a legal movement to better protect the rights of marginalized citizens. He has led landscape-changing civil rights cases and represented clients in a wide range of areas including civil rights, personal injury, labor and employment, class actions, and more. Ben Crump Law is dedicated to holding the powerful accountable. For more information, visit <a href="http://email2.sachsmedia.com/c/eJwdjs0OgjAQhJ8GjqS7bbftoQeM8h792Q0koqZgiG8vmsztm3wzNRpwgNIvERUqUAiImsANMIxXM4UbwGW6gaNx6ozaUpm3leuShvJc-zmqKlmETomvPmtvcyZWWRUSZp1Mf4_zvr-2To8dTmeO4xgyP0p7r6-_o8WWMrecljt_zgl-t4PzH-2RNUiq1YNRBIk0FBMcQQkG0ARtz0qwDjiI1c6DrUUZ_j1JIpiEgOULrEVCKw">www.bencrump.com</a>.</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-865561" class="share-twitter sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/865561/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-865561" class="share-facebook sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/865561/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-865561" class="share-linkedin sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/865561/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<div id="mvp-content-bot" class="left">
<div class="mvp-post-tags">
<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"><a href="https://eurweb.com/tag/ben-crump/" rel="tag">ben crump</a><a href="https://eurweb.com/tag/nigeria-anti-police-brutality-protest/" rel="tag">nigeria anti-police brutality protest</a></span>
</div>
<div class="posts-nav-link">
</div>
<div id="mvp-prev-next-wrap" class="left relative">
<div class="mvp-next-post-wrap right relative">
<a href="https://eurweb.com/2020/10/21/tia-mowry-reveals-that-she-and-husband-cory-hardrict-schedule-sex/" rel="bookmark">
<div class="mvp-prev-next-cont left relative">
<div class="mvp-next-cont-out left relative">
<div class="mvp-next-cont-in">
<div class="mvp-prev-next-text left relative">
<span class="mvp-prev-next-label left relative">Up Next</span>
<p>Tia Mowry Reveals That She And Husband Cory Hardrict Schedule Sex</p>
</div>
</div>
<span class="mvp-next-arr fa fa-chevron-right right"></span>
</div>
</div>
</a>
</div>
<div class="mvp-prev-post-wrap left relative">
<a href="https://eurweb.com/2020/10/21/shonda-rhimes-says-clash-over-disneyland-ticket-lead-to-abc-exit-i-felt-like-i-was-dying/" rel="bookmark">
<div class="mvp-prev-next-cont left relative">
<div class="mvp-prev-cont-out right relative">
<span class="mvp-prev-arr fa fa-chevron-left left"></span>
<div class="mvp-prev-cont-in">
<div class="mvp-prev-next-text left relative">
<span class="mvp-prev-next-label left relative">Don&#039;t Miss</span>
<p>Shonda Rhimes Says Clash Over Disneyland Ticket Lead to ABC Exit: &#8216;I Felt Like I Was Dying&#8217;</p>
</div>
</div>
</div>
</div>
</a>
</div>
</div>
<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<img src="https://eurweb.com/wp-content/uploads/2020/03/eurWeb-logo-final.png" />
<meta itemprop="url" content="https://eurweb.com/wp-content/uploads/2020/03/eurWeb-logo-final.png">
</div>
<meta itemprop="name" content="EURweb">
</div>
</div>
</div>
<div class="mvp-cont-read-wrap">
<div id="mvp-post-bot-ad" class="left relative">
<span class="mvp-ad-label">Advertisement</span>
<div id="zergnet-widget-60385"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=60385';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })(); 
</script>
<script data-minify="1" src="https://eurweb.com/wp-content/cache/min/1/anyclip-widget/lre-widget/prod/v1/src/lre-61a69e0b54c18bb090a0129a408ba9ba.js" pubname="eurwebcom" widgetname="0011r00001lcDtH_1722">
</script> </div>
<div id="mvp-related-posts" class="left relative">
<h4 class="mvp-widget-home-title">
<span class="mvp-widget-home-title">You may like</span>
</h4>
<ul class="mvp-related-posts-list left related">
<a href="https://eurweb.com/2020/10/20/ben-crump-statement-following-release-of-grand-juror-statements-in-breonna-taylor-case/" rel="bookmark">
<li>
<div class="mvp-related-img left relative">
<img width="400" height="240" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Breonna Taylor" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?resize=590%2C354&amp;ssl=1 590w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?resize=400%2C240&amp;ssl=1 400w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="842585" data-permalink="https://eurweb.com/2020/05/15/breonna-taylors-attorney-tells-louisville-police-get-your-damn-story-straight/hjvjuvl/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?fit=716%2C863&amp;ssl=1" data-orig-size="716,863" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Breonna Taylor" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?fit=249%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?fit=716%2C863&amp;ssl=1" /> <img width="80" height="80" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Breonna Taylor" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="842585" data-permalink="https://eurweb.com/2020/05/15/breonna-taylors-attorney-tells-louisville-police-get-your-damn-story-straight/hjvjuvl/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?fit=716%2C863&amp;ssl=1" data-orig-size="716,863" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Breonna Taylor" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?fit=249%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/hjvjuvl.png?fit=716%2C863&amp;ssl=1" /> </div>
<div class="mvp-related-text left relative">
<p>Ben Crump Statement Following Release of Grand Juror Statements in Breonna Taylor Case</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/09/21/ben-crump-and-geo-clinton-hold-news-conference-outside-sony-music-hq-on-lets-get-it-on-copyright-case/" rel="bookmark">
<li>
<div class="mvp-related-img left relative">
<img width="400" height="240" src="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="George Clinton &amp; George Clinton" srcset="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?w=578&amp;ssl=1 578w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?resize=300%2C180&amp;ssl=1 300w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?resize=400%2C240&amp;ssl=1 400w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="860828" data-permalink="https://eurweb.com/2020/09/21/ben-crump-and-geo-clinton-hold-news-conference-outside-sony-music-hq-on-lets-get-it-on-copyright-case/george-clinton-george-clinton/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?fit=578%2C347&amp;ssl=1" data-orig-size="578,347" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="George Clinton &#038; George Clinton" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?fit=300%2C180&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?fit=578%2C347&amp;ssl=1" /> <img width="80" height="80" src="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="George Clinton &amp; George Clinton" srcset="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="860828" data-permalink="https://eurweb.com/2020/09/21/ben-crump-and-geo-clinton-hold-news-conference-outside-sony-music-hq-on-lets-get-it-on-copyright-case/george-clinton-george-clinton/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?fit=578%2C347&amp;ssl=1" data-orig-size="578,347" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="George Clinton &#038; George Clinton" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?fit=300%2C180&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/09/George-Clinton-George-Clinton.jpg?fit=578%2C347&amp;ssl=1" /> </div>
<div class="mvp-related-text left relative">
<p>Ben Crump and Geo. Clinton Hold News Conference Outside Sony Music HQ on &#8216;Let&#8217;s Get It On&#8217; Copyright Case</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/09/17/cops-call-for-backup-instead-of-simply-handing-over-traffic-ticket-to-black-teen-mom-confronts-officers-watch/" rel="bookmark">
<li>
<div class="mvp-related-img left relative">
<img width="400" height="240" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Mom &amp; son" data-attachment-id="860247" data-permalink="https://eurweb.com/2020/09/17/cops-call-for-backup-instead-of-simply-handing-over-traffic-ticket-to-black-teen-mom-confronts-officers-watch/mom-son/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?fit=544%2C355&amp;ssl=1" data-orig-size="544,355" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Mom &#038; son" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?fit=300%2C196&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?fit=544%2C355&amp;ssl=1" /> <img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Mom &amp; son" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="860247" data-permalink="https://eurweb.com/2020/09/17/cops-call-for-backup-instead-of-simply-handing-over-traffic-ticket-to-black-teen-mom-confronts-officers-watch/mom-son/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?fit=544%2C355&amp;ssl=1" data-orig-size="544,355" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Mom &#038; son" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?fit=300%2C196&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Mom-son.jpg?fit=544%2C355&amp;ssl=1" /> </div>
<div class="mvp-related-text left relative">
<p>How Mom Handled Officer Who Called for Backup Instead of Simply Issuing Traffic Ticket to Her Teen Son (Watch)</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/09/02/ben-crump-to-represent-family-of-dijon-kizzee-killed-by-la-sheriff-deputies-get-link-to-live-stream/" rel="bookmark">
<li>
<div class="mvp-related-img left relative">
<img width="400" height="240" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Dijon Kizzee1 - IMG_1067-e1598938479636" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?resize=590%2C354&amp;ssl=1 590w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?resize=400%2C240&amp;ssl=1 400w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="857947" data-permalink="https://eurweb.com/2020/08/31/la-activists-set-press-conference-today-over-fatal-shooting-of-black-man-by-sheriff-deputies/dijon-kizzee1-img_1067-e1598938479636/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?fit=604%2C387&amp;ssl=1" data-orig-size="604,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Dijon Kizzee1 &#8211; IMG_1067-e1598938479636" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?fit=300%2C192&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?fit=604%2C387&amp;ssl=1" /> <img width="80" height="80" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Dijon Kizzee1 - IMG_1067-e1598938479636" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="857947" data-permalink="https://eurweb.com/2020/08/31/la-activists-set-press-conference-today-over-fatal-shooting-of-black-man-by-sheriff-deputies/dijon-kizzee1-img_1067-e1598938479636/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?fit=604%2C387&amp;ssl=1" data-orig-size="604,387" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Dijon Kizzee1 &#8211; IMG_1067-e1598938479636" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?fit=300%2C192&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/08/Dijon-Kizzee1-IMG_1067-e1598938479636.jpg?fit=604%2C387&amp;ssl=1" /> </div>
<div class="mvp-related-text left relative">
<p>Ben Crump to Represent Family of Dijon Kizzee Killed by LA Sheriff Deputies / Get Link to Live Stream</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/09/01/ben-crump-denounces-prosecutors-efforts-to-posthumously-frame-breonna-taylor/" rel="bookmark">
<li>
<div class="mvp-related-img left relative">
<img width="400" height="240" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Breonna Taylor1 (Facebook)" data-attachment-id="858081" data-permalink="https://eurweb.com/2020/09/01/ben-crump-denounces-prosecutors-efforts-to-posthumously-frame-breonna-taylor/breonna-taylor1-facebook/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?fit=518%2C308&amp;ssl=1" data-orig-size="518,308" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Breonna Taylor1 (Facebook)" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?fit=300%2C178&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?fit=518%2C308&amp;ssl=1" /> <img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Breonna Taylor1 (Facebook)" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="858081" data-permalink="https://eurweb.com/2020/09/01/ben-crump-denounces-prosecutors-efforts-to-posthumously-frame-breonna-taylor/breonna-taylor1-facebook/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?fit=518%2C308&amp;ssl=1" data-orig-size="518,308" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Breonna Taylor1 (Facebook)" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?fit=300%2C178&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/09/Breonna-Taylor1-Facebook.jpg?fit=518%2C308&amp;ssl=1" /> </div>
<div class="mvp-related-text left relative">
<p>Ben Crump Denounces Prosecutors&#8217; Efforts to Posthumously Frame Breonna Taylor</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/08/31/crump-and-co-counsels-release-statement-to-president-trump-on-behalf-of-blake-family/" rel="bookmark">
<li>
<div class="mvp-related-img left relative">
<img width="400" height="240" src="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Blake Family &amp; Ben Crump" srcset="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?resize=590%2C354&amp;ssl=1 590w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?resize=400%2C240&amp;ssl=1 400w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="857914" data-permalink="https://eurweb.com/2020/08/31/crump-and-co-counsels-release-statement-to-president-trump-on-behalf-of-blake-family/blake-family-ben-crump/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?fit=731%2C483&amp;ssl=1" data-orig-size="731,483" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Blake Family &#038; Ben Crump" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?fit=300%2C198&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?fit=731%2C483&amp;ssl=1" /> <img width="80" height="80" src="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Blake Family &amp; Ben Crump" srcset="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="857914" data-permalink="https://eurweb.com/2020/08/31/crump-and-co-counsels-release-statement-to-president-trump-on-behalf-of-blake-family/blake-family-ben-crump/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?fit=731%2C483&amp;ssl=1" data-orig-size="731,483" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Blake Family &#038; Ben Crump" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?fit=300%2C198&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/08/Blake-Family-Ben-Crump.jpg?fit=731%2C483&amp;ssl=1" /> </div>
<div class="mvp-related-text left relative">
<p>Crump and Co-counsels Release Statement to President Trump on Behalf of Blake Family</p>
</div>
</li>
</a>
</ul> </div>
<div id="mvp-comments-button" class="left relative mvp-com-click">
<span class="mvp-comment-but-text">Click to comment</span>
</div>
<div id="comments" class="mvp-com-click-id-865561 mvp-com-click-main">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/10/21/865561/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://eurweb.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='865561' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="50d006b2ec" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="132" /></p></form> </div>
</div> </div>
</div>
</div>
</div>
</div>
<div id="mvp-post-add-box">
<div id="mvp-post-add-wrap" class="left relative">
<div class="mvp-post-add-story left relative">
<div class="mvp-post-add-head left relative">
<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://eurweb.com/category/news-2/blacklivesmatter/"><span class="mvp-post-cat left">#BlackLivesMatter</span></a></h3>
<h1 class="mvp-post-title left">Ohio Business Owner Says His &#8216;White Lives Matter, Who Else Will Pay for Welfare&#8217; Sign is Not Racist (Watch)</h1>
<div class="mvp-author-info-wrap left relative">
<div class="mvp-author-info-thumb left relative">
<img alt='' src='https://secure.gravatar.com/avatar/54a26a30774aaab0b505ea0e1d14eecf?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/54a26a30774aaab0b505ea0e1d14eecf?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /> </div>
<div class="mvp-author-info-text left relative">
<div class="mvp-author-info-date left relative">
<p>Published</p> <span class="mvp-post-date">6 hours ago</span> <p>on</p> <span class="mvp-post-date">October 21, 2020</span>
</div>
<div class="mvp-author-info-name left relative">
<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://eurweb.com/author/euradmin02/" title="Posts by EURPublisher01" rel="author">EURPublisher01</a></span> </div>
</div>
</div>
</div>
<div class="mvp-post-add-body left relative">
<div class="mvp-post-add-img left relative">
<img width="900" height="675" src="https://eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg" class="attachment- size- wp-post-image" alt="mikes-tires-sign" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?resize=768%2C576&amp;ssl=1 768w" sizes="(max-width: 900px) 100vw, 900px" data-attachment-id="865458" data-permalink="https://eurweb.com/2020/10/21/ohio-business-owner-says-his-white-lives-matter-who-else-will-pay-for-welfare-sign-is-not-racist-watch/mikes-tires-sign/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?fit=900%2C675&amp;ssl=1" data-orig-size="900,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mikes-tires-sign" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?fit=740%2C555&amp;ssl=1" /> </div>
<div class="mvp-post-add-cont left relative">
<div class="mvp-post-add-main right relative">
<p><iframe src="https://w3.cdn.anvato.net/player/prod/v3/anvload.html?key=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%3D" width="640" height="360" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></p>
<p>*The owner of a tire shop in Bethesda, Ohio has put a sign outside his door that has been labeled as racist, although he claims it wasn&#8217;t his intention.</p>
<p>“My sign states white lives matter, who else will pay for welfare. That is a question, not a statement, it doesn&#8217;t have a question mark at the end because I don&#8217;t have one to put there,” said Mike of Mike’s Tires, who also placed &#8220;Trump 2020&#8221; on the sign and defends the whole gesture as freedom of speech.</p>
<p>The president of the Belmont County chapter of the NAACP says the sign should be taken down as it promotes false information.</p>
<p>“We actually all pay for welfare recipients to receive their benefits,” said Belmont County NAACP President <strong>Jerry Moore</strong>. “When you just take facts out of thin air and put them on a billboard and call them facts, when they are your opinions, that becomes a problem.&#8221;</p>
<p>The business owner says the community is blowing it out of proportion.</p>
<p>“If you want to call it racist, you have that right, but I also have the right to put out on my sign, in my yard, what I want,” said Mike. “I&#8217;m not a racist person, I have black customers, black people deliver tires to me, I have nothing against them.&#8221;</p>
<p>Watch an interview with Mike and Jerry Moore in this news report below:</p>
<p><iframe id="19346346-iframe" class="wral-embedded-player" style="width: 576px; height: 324px; background-color: transparent; border: 0px none transparent; padding: 0px; overflow: hidden;" src="https://www.wral.com/ohio-business-under-fire-for-racist-sign/19346346/?version=embedded_v2&amp;player_options=%257B%2522embedded_autoplay_next%2522%253Atrue%257D" allowfullscreen="allowfullscreen"></iframe></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-865456" class="share-twitter sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/ohio-business-owner-says-his-white-lives-matter-who-else-will-pay-for-welfare-sign-is-not-racist-watch/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-865456" class="share-facebook sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/ohio-business-owner-says-his-white-lives-matter-who-else-will-pay-for-welfare-sign-is-not-racist-watch/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-865456" class="share-linkedin sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/ohio-business-owner-says-his-white-lives-matter-who-else-will-pay-for-welfare-sign-is-not-racist-watch/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<div class="mvp-post-add-link">
<a href="https://eurweb.com/2020/10/21/ohio-business-owner-says-his-white-lives-matter-who-else-will-pay-for-welfare-sign-is-not-racist-watch/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
</div>
</div>
</div>
</div>
<div class="mvp-post-add-story left relative">
<div class="mvp-post-add-head left relative">
<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://eurweb.com/category/news-2/headlines/"><span class="mvp-post-cat left">Top News</span></a></h3>
<h1 class="mvp-post-title left">&#8216;This Is Not Kneeling On A Neck&#8217;: Cop Shot During Breonna Taylor Raid Says It Was &#8216;Not a Race Thing&#8217; (Watch)</h1>
<div class="mvp-author-info-wrap left relative">
<div class="mvp-author-info-thumb left relative">
<img alt='' src='https://secure.gravatar.com/avatar/54a26a30774aaab0b505ea0e1d14eecf?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/54a26a30774aaab0b505ea0e1d14eecf?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /> </div>
<div class="mvp-author-info-text left relative">
<div class="mvp-author-info-date left relative">
<p>Published</p> <span class="mvp-post-date">14 hours ago</span> <p>on</p> <span class="mvp-post-date">October 21, 2020</span>
</div>
<div class="mvp-author-info-name left relative">
<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://eurweb.com/author/euradmin02/" title="Posts by EURPublisher01" rel="author">EURPublisher01</a></span> </div>
</div>
</div>
</div>
<div class="mvp-post-add-body left relative">
<div class="mvp-post-add-img left relative">
<img width="634" height="386" src="https://eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg" class="attachment- size- wp-post-image" alt="Sgt Jonathan Mattingly" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?w=634&amp;ssl=1 634w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?resize=300%2C183&amp;ssl=1 300w" sizes="(max-width: 634px) 100vw, 634px" data-attachment-id="865453" data-permalink="https://eurweb.com/2020/10/21/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch/sgt-jonathan-mattingly/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?fit=634%2C386&amp;ssl=1" data-orig-size="634,386" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Sgt Jonathan Mattingly" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?fit=300%2C183&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?fit=634%2C386&amp;ssl=1" /> </div>
<div class="mvp-post-add-cont left relative">
<div class="mvp-post-add-main right relative">
<div id="attachment_865453" style="width: 644px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-865453" data-attachment-id="865453" data-permalink="https://eurweb.com/2020/10/21/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch/sgt-jonathan-mattingly/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?fit=634%2C386&amp;ssl=1" data-orig-size="634,386" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Sgt Jonathan Mattingly" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?fit=300%2C183&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?fit=634%2C386&amp;ssl=1" class="size-full wp-image-865453" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?resize=634%2C386&#038;ssl=1" alt="Sgt Jonathan Mattingly" width="634" height="386" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?w=634&amp;ssl=1 634w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?resize=300%2C183&amp;ssl=1 300w" sizes="(max-width: 634px) 100vw, 634px" data-recalc-dims="1" /><p id="caption-attachment-865453" class="wp-caption-text">Sgt. Jonathan Mattingly (ABC News)</p></div>
<p>*<strong>Sgt. Jonathan Mattingly</strong>, the officer who was shot in the leg while carrying out a search warrant at <strong>Breonna Taylor&#8217;s</strong> apartment, seems to think that because none of the officers knelt on her neck as in the <strong>George Floyd</strong> police killing, that race shouldn&#8217;t be a factor in their case.</p>
<p>Speaking out for the first time exclusively to ABC News and The Courier Journal in Louisville Tuesday, Mattingly said, &#8220;This is not relatable to George Floyd. This is nothing like that.&#8221;</p>
<p>Mattingly has been accused of raiding Taylor&#8217;s house under the guise of a narcotics investigation. The officers claimed that they were executing a late-night &#8220;no-knock'&#8221; warrant. Mattingly said he was shot at by Taylor&#8217;s boyfriend, after which the police opened fire which resulted in Taylor&#8217;s death.</p>
<p>None of the officers have been charged with the death of Taylor, and Kentucky Attorney General <strong>Daniel Cameron</strong> is under fire from critics.</p>
<p>&#8220;It&#8217;s not a race thing like people want to try to make it to be. It&#8217;s not. This is a point where we were doing our job, we gave too much time when we go in, I get shot, we returned fire,&#8221; Mattingly said in the interview.</p>
<p>&#8220;This is not us going, hunting somebody down. This is not kneeling on a neck. It&#8217;s nothing like that.&#8221; he added.</p>
<p>Watch below:</p>
<p><iframe src="https://www.youtube.com/embed/GG7OOKbJxOE" width="640" height="380" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-865452" class="share-twitter sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-865452" class="share-facebook sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-865452" class="share-linkedin sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<div class="mvp-post-add-link">
<a href="https://eurweb.com/2020/10/21/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
</div>
</div>
</div>
</div>
<div class="mvp-post-add-story left relative">
<div class="mvp-post-add-head left relative">
<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://eurweb.com/category/news-2/blacklivesmatter/"><span class="mvp-post-cat left">#BlackLivesMatter</span></a></h3>
<h1 class="mvp-post-title left">White Woman Yells &#8216;F*** Black Lives Matter&#8217; to Starbucks Barista During Mask Rant (Watch)</h1>
<div class="mvp-author-info-wrap left relative">
<div class="mvp-author-info-thumb left relative">
<img alt='' src='https://secure.gravatar.com/avatar/54a26a30774aaab0b505ea0e1d14eecf?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/54a26a30774aaab0b505ea0e1d14eecf?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /> </div>
<div class="mvp-author-info-text left relative">
<div class="mvp-author-info-date left relative">
<p>Published</p> <span class="mvp-post-date">17 hours ago</span> <p>on</p> <span class="mvp-post-date">October 21, 2020</span>
</div>
<div class="mvp-author-info-name left relative">
<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://eurweb.com/author/euradmin02/" title="Posts by EURPublisher01" rel="author">EURPublisher01</a></span> </div>
</div>
</div>
</div>
<div class="mvp-post-add-body left relative">
<div class="mvp-post-add-img left relative">
<img width="1920" height="1080" src="https://eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg" class="attachment- size- wp-post-image" alt="f_mo_mask_racist_201020" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?w=1480&amp;ssl=1 1480w" sizes="(max-width: 1920px) 100vw, 1920px" data-attachment-id="865426" data-permalink="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/f_mo_mask_racist_201020/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?fit=1920%2C1080&amp;ssl=1" data-orig-size="1920,1080" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="f_mo_mask_racist_201020" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?fit=740%2C416&amp;ssl=1" /> </div>
<div class="mvp-post-add-cont left relative">
<div class="mvp-post-add-main right relative">
<div id="i4c-draggable-container" style="position: fixed; z-index: 1499; width: 0px; height: 0px;">
<div class="resolved" style="all: initial;" data-reactroot=""></div>
</div>
<div id="attachment_865426" style="width: 668px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-865426" data-attachment-id="865426" data-permalink="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/f_mo_mask_racist_201020/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?fit=1920%2C1080&amp;ssl=1" data-orig-size="1920,1080" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="f_mo_mask_racist_201020" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?fit=740%2C416&amp;ssl=1" class=" wp-image-865426" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=658%2C370&#038;ssl=1" alt="f_mo_mask_racist_201020" width="658" height="370" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?w=1480&amp;ssl=1 1480w" sizes="(max-width: 658px) 100vw, 658px" data-recalc-dims="1" /><p id="caption-attachment-865426" class="wp-caption-text">Alex Beckom addresses a maskless customer at a Starbucks in Santee, Calif. before things go left</p></div>
<p>*A Black barista working at a Starbucks in Santee, Calif. Was the victim of a racist rant by a white customer over the weekend.</p>
<p>According to the viral video, a young, white woman began berating African-American employee <strong>Alex Beckom</strong> after she politely asked the customer to wear her face mask in the Oct. 17 incident.</p>
<p>“When you talk to me like that, I know it’s because you’re discriminating against me because I’m a Trump supporter,” said the unidentified customer. “F&#8212; Black Lives Matter.&#8221;</p>
<p>After Beckom gave the customer the sugar she asked for, she calmly said to the woman, “The next time you come in, I need you to keep a mask on.”</p>
<p>The woman snapped back, &#8220;It’s not a law! It’s a hoax! I don’t have to wear a mask. I’m not going to wear a mask. This is America. I don’t have to do what you say! Trump 2020!”</p>
<p>Beckom then calmly asked her to leave. The woman left, then poked her head back in to shout one more “F&#8212; Black Lives Matter!” before exiting for good.</p>
<div id="attachment_865427" style="width: 609px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-865427" data-attachment-id="865427" data-permalink="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/sotvo-santee-starbucks-_knsdcpkn/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?fit=1920%2C1080&amp;ssl=1" data-orig-size="1920,1080" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SOTVO-SANTEE-STARBUCKS-_KNSDCPKN" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?fit=740%2C416&amp;ssl=1" class=" wp-image-865427" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?resize=599%2C337&#038;ssl=1" alt="SOTVO-SANTEE-STARBUCKS-_KNSDCPKN" width="599" height="337" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?w=1920&amp;ssl=1 1920w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?resize=1536%2C864&amp;ssl=1 1536w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/SOTVO-SANTEE-STARBUCKS-_KNSDCPKN.jpg?w=1480&amp;ssl=1 1480w" sizes="(max-width: 599px) 100vw, 599px" data-recalc-dims="1" /><p id="caption-attachment-865427" class="wp-caption-text">Starbucks barista Alex Beckom (San Diego&#8217;s KNSD)</p></div>
<p>Beckom told San Diego TV station KNSD that the customer reportedly had pulled down her mask to speak to another barista.</p>
<p>“I’m Black in America, so I’ve dealt with these kinds of situations before,” explained the 19-year-old worker. &#8220;So I am able to stay calm and collected in these types of situations because I don’t want to risk my job.”</p>
<p>Watch the incident below, or <a href="https://twitter.com/Alex_beckom/status/1317973883270569985">here on Twitter</a>:</p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Welcome to my day at work🥰 <a href="https://twitter.com/hashtag/starbucks?src=hash&amp;ref_src=twsrc%5Etfw">#starbucks</a> <a href="https://twitter.com/hashtag/karen?src=hash&amp;ref_src=twsrc%5Etfw">#karen</a> <a href="https://twitter.com/Starbucks?ref_src=twsrc%5Etfw">@Starbucks</a> <a href="https://t.co/six8s4qCAx">pic.twitter.com/six8s4qCAx</a></p>
<p>— A l e x🧚‍♀️ (@Alex_beckom) <a href="https://twitter.com/Alex_beckom/status/1317973883270569985?ref_src=twsrc%5Etfw">October 18, 2020</a></p></blockquote>
<p><iframe style="border: 1px solid #e6e6e6;" src="https://cbs8.com/embeds/video/509-7bba46f0-3c1c-4106-ae90-c64b5f8da4ef/iframe" width="640" height="360" allowfullscreen="allowfullscreen"></iframe></p>
<div id="i4c-dialogs-container"></div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-865425" class="share-twitter sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-865425" class="share-facebook sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-865425" class="share-linkedin sd-button share-icon no-text" href="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
<div class="mvp-post-add-link">
<a href="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="mvp-side-wrap" class="left relative theiaStickySidebar">
<section id="text-139" class="mvp-side-widget widget_text"> <div class="textwidget"><p><script data-minify="1" type="text/javascript" src="https://eurweb.com/wp-content/cache/min/1/player/build/brid.min-b6d00c26ca85f35daa02fce1222a3498.js"></script></p>
<div id="Brid_82663964" class="brid" style="width: 320; height: 270;"></div>
<p><script type="text/javascript"> $bp("Brid_82663964", {"id":"10393","width":"320","height":"270","playlist":"4011"}); </script></p>
</div>
</section><section id="mvp_tabber_widget-7" class="mvp-side-widget mvp_tabber_widget">
<div class="mvp-widget-tab-wrap left relative">
<div class="mvp-feat1-list-wrap left relative">
<div class="mvp-feat1-list-head-wrap left relative">
<ul class="mvp-feat1-list-buts left relative">
<li class="mvp-feat-col-tab"><a href="#mvp-tab-col1"><span class="mvp-feat1-list-but">Social Heat</span></a></li>
<li><a href="#mvp-tab-col2"><span class="mvp-feat1-list-but">Today’s Video</span></a></li>
<li><a href="#mvp-tab-col3"><span class="mvp-feat1-list-but">Podcasts</span></a></li>
</ul>
</div>
<div id="mvp-tab-col1" class="mvp-feat1-list left relative mvp-tab-col-cont">
<a href="https://eurweb.com/2020/10/21/tia-mowry-reveals-that-she-and-husband-cory-hardrict-schedule-sex/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
 <div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Cory-Tia1-gettyimages-1204568294-2048x2048-1.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Cory &amp; Tia1- gettyimages-1204568294-2048x2048" srcset="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Cory-Tia1-gettyimages-1204568294-2048x2048-1.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Cory-Tia1-gettyimages-1204568294-2048x2048-1.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Cory-Tia1-gettyimages-1204568294-2048x2048-1.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="865542" data-permalink="https://eurweb.com/2020/10/21/tia-mowry-reveals-that-she-and-husband-cory-hardrict-schedule-sex/cory-tia1-gettyimages-1204568294-2048x2048/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Cory-Tia1-gettyimages-1204568294-2048x2048-1.jpg?fit=590%2C332&amp;ssl=1" data-orig-size="590,332" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cory &#038; Tia1- gettyimages-1204568294-2048&#215;2048" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Cory-Tia1-gettyimages-1204568294-2048x2048-1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Cory-Tia1-gettyimages-1204568294-2048x2048-1.jpg?fit=590%2C332&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/social-heat/">
Social Heat</a> </span><span class="mvp-cd-date left relative">1 hour ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/21/tia-mowry-reveals-that-she-and-husband-cory-hardrict-schedule-sex/">Tia Mowry Reveals That She And Husband Cory Hardrict Schedule Sex</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/20/wanna-see-bill-cosbys-newest-mug-shot-weve-got-it-click-to-see/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Bill-Cosby-mugshot.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Bill Cosby mugshot" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Bill-Cosby-mugshot.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Bill-Cosby-mugshot.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Bill-Cosby-mugshot.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="865342" data-permalink="https://eurweb.com/2020/10/20/wanna-see-bill-cosbys-newest-mug-shot-weve-got-it-click-to-see/bill-cosby-mugshot-3/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Bill-Cosby-mugshot.jpg?fit=534%2C318&amp;ssl=1" data-orig-size="534,318" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Bill Cosby mugshot" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Bill-Cosby-mugshot.jpg?fit=300%2C179&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Bill-Cosby-mugshot.jpg?fit=534%2C318&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/social-heat/">
Social Heat</a> </span><span class="mvp-cd-date left relative">1 day ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/20/wanna-see-bill-cosbys-newest-mug-shot-weve-got-it-click-to-see/">Wanna See Bill Cosby&#8217;s NEWEST Mug Shot? We&#8217;ve Got it / Look!</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/20/melania-trump-cancels-tonights-campaign-appearance-over-lingering-covid-19-cough/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/MelaniaTrumpFirstLadyMelaniaTrumpVisitsJEz0fCLC-LXl-1-e1601662342945.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Melania+Trump+First+Lady+Melania+Trump+Visits+JEz0fCLC-LXl (1)" srcset="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/MelaniaTrumpFirstLadyMelaniaTrumpVisitsJEz0fCLC-LXl-1-e1601662342945.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/MelaniaTrumpFirstLadyMelaniaTrumpVisitsJEz0fCLC-LXl-1-e1601662342945.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/MelaniaTrumpFirstLadyMelaniaTrumpVisitsJEz0fCLC-LXl-1-e1601662342945.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="862700" data-permalink="https://eurweb.com/2020/10/02/melania-trump-secretly-recorded-ranting-against-obama-and-trumps-immigration-policies-listen/melaniatrumpfirstladymelaniatrumpvisitsjez0fclc-lxl-1/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/MelaniaTrumpFirstLadyMelaniaTrumpVisitsJEz0fCLC-LXl-1-e1601662342945.jpg?fit=597%2C336&amp;ssl=1" data-orig-size="597,336" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Melania+Trump+First+Lady+Melania+Trump+Visits+JEz0fCLC-LXl (1)" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/MelaniaTrumpFirstLadyMelaniaTrumpVisitsJEz0fCLC-LXl-1-e1601662342945.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/MelaniaTrumpFirstLadyMelaniaTrumpVisitsJEz0fCLC-LXl-1-e1601662342945.jpg?fit=597%2C336&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">
<a href="https://eurweb.com/category/social-heat/"> Social Heat</a>
</span><span class="mvp-cd-date left relative">1 day ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/20/melania-trump-cancels-tonights-campaign-appearance-over-lingering-covid-19-cough/">Melania Trump Cancels Tonight&#8217;s Campaign Appearance Over Lingering (COVID-19) Cough</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/20/r-kellys-latest-request-for-release-denied-after-alleged-beating-in-lockdown/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/R-Kelly1-Getty.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="R Kelly1 (Getty)" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/R-Kelly1-Getty.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/R-Kelly1-Getty.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/R-Kelly1-Getty.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="865281" data-permalink="https://eurweb.com/2020/10/20/r-kellys-latest-request-for-release-denied-after-alleged-beating-in-lockdown/r-kelly1-getty/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/R-Kelly1-Getty.jpg?fit=590%2C333&amp;ssl=1" data-orig-size="590,333" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="R Kelly1 (Getty)" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/R-Kelly1-Getty.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/R-Kelly1-Getty.jpg?fit=590%2C333&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/social-heat/">
Social Heat</a> </span><span class="mvp-cd-date left relative">2 days ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/20/r-kellys-latest-request-for-release-denied-after-alleged-beating-in-lockdown/">R. Kelly&#8217;s Latest Request for Release Denied After Alleged Beating in Lockdown</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/19/cynthia-bailey-mike-hills-wedding-not-filmed-by-bravo-over-covid-19-concerns/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/Cynthia-Bailey-and-Mike-Hill.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Cynthia Bailey and Mike Hill" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/Cynthia-Bailey-and-Mike-Hill.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/Cynthia-Bailey-and-Mike-Hill.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/Cynthia-Bailey-and-Mike-Hill.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="813496" data-permalink="https://eurweb.com/2020/01/07/cynthia-bailey-and-mike-hill-are-all-about-a-prenup-ive-had-my-money-taken-before/cynthia-bailey-and-mike-hill/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/Cynthia-Bailey-and-Mike-Hill.jpg?fit=620%2C350&amp;ssl=1" data-orig-size="620,350" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cynthia Bailey and Mike Hill" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/Cynthia-Bailey-and-Mike-Hill.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/Cynthia-Bailey-and-Mike-Hill.jpg?fit=620%2C350&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/social-heat/">
Social Heat</a> </span><span class="mvp-cd-date left relative">2 days ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/19/cynthia-bailey-mike-hills-wedding-not-filmed-by-bravo-over-covid-19-concerns/">Cynthia Bailey &#038; Mike Hill&#8217;s Wedding Not Filmed by Bravo Over COVID-19 Concerns</a></h2>
</div>
</div>
</div>
</div>
</a>
</div>
<div id="mvp-tab-col2" class="mvp-feat1-list left relative mvp-tab-col-cont">
<a href="https://eurweb.com/2020/10/21/ohio-business-owner-says-his-white-lives-matter-who-else-will-pay-for-welfare-sign-is-not-racist-watch/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="mikes-tires-sign" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="865458" data-permalink="https://eurweb.com/2020/10/21/ohio-business-owner-says-his-white-lives-matter-who-else-will-pay-for-welfare-sign-is-not-racist-watch/mikes-tires-sign/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?fit=900%2C675&amp;ssl=1" data-orig-size="900,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mikes-tires-sign" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/mikes-tires-sign.jpg?fit=740%2C555&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/news-2/blacklivesmatter/">
#BlackLivesMatter</a> </span> <span class="mvp-cd-date left relative">6 hours ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/21/ohio-business-owner-says-his-white-lives-matter-who-else-will-pay-for-welfare-sign-is-not-racist-watch/">Ohio Business Owner Says His &#8216;White Lives Matter, Who Else Will Pay for Welfare&#8217; Sign is Not Racist (Watch)</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/21/obama-to-address-black-men-specifically-in-tonights-drive-in-rally-for-biden-video/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/original.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="original" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/original.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/original.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/original.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="865467" data-permalink="https://eurweb.com/2020/10/21/obama-to-address-black-men-specifically-in-tonights-drive-in-rally-for-biden-video/original-3/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/original.jpg?fit=720%2C405&amp;ssl=1" data-orig-size="720,405" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="original" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/original.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/original.jpg?fit=720%2C405&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/news-2/obamapolitical/">
Obama/Trump/Political</a> </span> <span class="mvp-cd-date left relative">9 hours ago</span>
</div>
 <h2><a style="color:#222" href="https://eurweb.com/2020/10/21/obama-to-address-black-men-specifically-in-tonights-drive-in-rally-for-biden-video/">Obama to Address Black Men Specifically in Tonight&#8217;s Drive-In Rally for Biden (Video)</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/21/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Sgt Jonathan Mattingly" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="865453" data-permalink="https://eurweb.com/2020/10/21/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch/sgt-jonathan-mattingly/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?fit=634%2C386&amp;ssl=1" data-orig-size="634,386" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Sgt Jonathan Mattingly" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?fit=300%2C183&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Sgt-Jonathan-Mattingly.jpg?fit=634%2C386&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">
<a href="https://eurweb.com/category/todays-video/"> Today’s Video</a>
</span> <span class="mvp-cd-date left relative">14 hours ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/21/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch/">&#8216;This Is Not Kneeling On A Neck&#8217;: Cop Shot During Breonna Taylor Raid Says It Was &#8216;Not a Race Thing&#8217; (Watch)</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/21/rapper-nuke-bizzle-arrested-after-bragging-about-unemployment-fraud-in-song-watch/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nuke-Bizzle.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Nuke Bizzle" srcset="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nuke-Bizzle.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nuke-Bizzle.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nuke-Bizzle.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="865436" data-permalink="https://eurweb.com/2020/10/21/rapper-nuke-bizzle-arrested-after-bragging-about-unemployment-fraud-in-song-watch/nuke-bizzle/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nuke-Bizzle.jpg?fit=800%2C526&amp;ssl=1" data-orig-size="800,526" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Nuke Bizzle" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nuke-Bizzle.jpg?fit=300%2C197&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nuke-Bizzle.jpg?fit=740%2C487&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">
<a href="https://eurweb.com/category/todays-video/"> Today’s Video</a>
</span> <span class="mvp-cd-date left relative">15 hours ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/21/rapper-nuke-bizzle-arrested-after-bragging-about-unemployment-fraud-in-song-watch/">Rapper Nuke Bizzle Arrested After Bragging About Unemployment Fraud in Song (Watch)</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="f_mo_mask_racist_201020" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="865426" data-permalink="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/f_mo_mask_racist_201020/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?fit=1920%2C1080&amp;ssl=1" data-orig-size="1920,1080" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="f_mo_mask_racist_201020" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/f_mo_mask_racist_201020.jpg?fit=740%2C416&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">
<a href="https://eurweb.com/category/todays-video/"> Today’s Video</a>
</span> <span class="mvp-cd-date left relative">17 hours ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/21/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch/">White Woman Yells &#8216;F*** Black Lives Matter&#8217; to Starbucks Barista During Mask Rant (Watch)</a></h2>
</div>
</div>
</div>
</div>
</a>
</div>
<div id="mvp-tab-col3" class="mvp-feat1-list left relative mvp-tab-col-cont">
<a href="https://eurweb.com/2020/10/16/radioscope-raw-podcast-our-uncut-1989-interview-with-gladys-knight-and-the-pips/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CXLT7mMWQAEgPnq.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="CXLT7mMWQAEgPnq" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CXLT7mMWQAEgPnq.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CXLT7mMWQAEgPnq.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CXLT7mMWQAEgPnq.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="864896" data-permalink="https://eurweb.com/2020/10/16/radioscope-raw-podcast-our-uncut-1989-interview-with-gladys-knight-and-the-pips/cxlt7mmwqaegpnq/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CXLT7mMWQAEgPnq.jpg?fit=1200%2C675&amp;ssl=1" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CXLT7mMWQAEgPnq" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CXLT7mMWQAEgPnq.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CXLT7mMWQAEgPnq.jpg?fit=740%2C416&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">
<a href="https://eurweb.com/category/radioscope-oldschool/"> RadioScope-OldSchool</a>
</span><span class="mvp-cd-date left relative">5 days ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/16/radioscope-raw-podcast-our-uncut-1989-interview-with-gladys-knight-and-the-pips/">RADIOSCOPE RAW Podcast: Our Uncut 1989 Interview with Gladys Knight and the Pips</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/13/new-blm-inspired-gimlet-spotify-podcast-resistance-premiers-tomorrow-listen-to-trailer/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Resistance-Saidu-Tejan-Thomas-Jr.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Resistance - Saidu Tejan-Thomas Jr" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Resistance-Saidu-Tejan-Thomas-Jr.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Resistance-Saidu-Tejan-Thomas-Jr.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Resistance-Saidu-Tejan-Thomas-Jr.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="864419" data-permalink="https://eurweb.com/2020/10/13/new-blm-inspired-gimlet-spotify-podcast-resistance-premiers-tomorrow-listen-to-trailer/resistance-saidu-tejan-thomas-jr/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Resistance-Saidu-Tejan-Thomas-Jr.jpg?fit=543%2C320&amp;ssl=1" data-orig-size="543,320" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Resistance &#8211; Saidu Tejan-Thomas Jr" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Resistance-Saidu-Tejan-Thomas-Jr.jpg?fit=300%2C177&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/Resistance-Saidu-Tejan-Thomas-Jr.jpg?fit=543%2C320&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/podcasts/">
Podcasts</a> </span><span class="mvp-cd-date left relative">1 week ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/13/new-blm-inspired-gimlet-spotify-podcast-resistance-premiers-tomorrow-listen-to-trailer/">New BLM-Inspired Gimlet/Spotify Podcast ‘Resistance’ Premiers Tomorrow / LISTEN to Trailer</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/13/common-to-host-new-podcast-series-for-audible-mind-power-mixtape/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CommonLAPremiereCirqueDuSoleilVoltah4SJYa21eOZl-1-e1602602899442.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Common+LA+Premiere+Cirque+Du+Soleil+Volta+h4SJYa21eOZl (1)" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CommonLAPremiereCirqueDuSoleilVoltah4SJYa21eOZl-1-e1602602899442.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CommonLAPremiereCirqueDuSoleilVoltah4SJYa21eOZl-1-e1602602899442.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CommonLAPremiereCirqueDuSoleilVoltah4SJYa21eOZl-1-e1602602899442.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="864328" data-permalink="https://eurweb.com/2020/10/13/common-to-host-new-podcast-series-for-audible-mind-power-mixtape/commonlapremierecirquedusoleilvoltah4sjya21eozl-1/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CommonLAPremiereCirqueDuSoleilVoltah4SJYa21eOZl-1-e1602602899442.jpg?fit=598%2C342&amp;ssl=1" data-orig-size="598,342" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Common+LA+Premiere+Cirque+Du+Soleil+Volta+h4SJYa21eOZl (1)" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CommonLAPremiereCirqueDuSoleilVoltah4SJYa21eOZl-1-e1602602899442.jpg?fit=300%2C172&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/10/CommonLAPremiereCirqueDuSoleilVoltah4SJYa21eOZl-1-e1602602899442.jpg?fit=598%2C342&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/news-2/black-celebrity-gossip-gossip/">
Black Celebrity Gossip - Gossip</a> </span><span class="mvp-cd-date left relative">1 week ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/13/common-to-host-new-podcast-series-for-audible-mind-power-mixtape/">Common to Host New Podcast Series for Audible, &#8216;Mind Power Mixtape&#8217;</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/11/this-week-on-fox-las-culture-conversations-free-marie-and-rocsi-diaz/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Free-Rocsi-Culture-Conversations.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Free &amp; Rocsi - Culture Conversations" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Free-Rocsi-Culture-Conversations.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Free-Rocsi-Culture-Conversations.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Free-Rocsi-Culture-Conversations.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="863824" data-permalink="https://eurweb.com/2020/10/11/this-week-on-fox-las-culture-conversations-free-marie-and-rocsi-diaz/free-rocsi-culture-conversations/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Free-Rocsi-Culture-Conversations.jpg?fit=655%2C360&amp;ssl=1" data-orig-size="655,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Free &#038; Rocsi &#8211; Culture Conversations" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Free-Rocsi-Culture-Conversations.jpg?fit=300%2C165&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Free-Rocsi-Culture-Conversations.jpg?fit=655%2C360&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/podcasts/">
Podcasts</a> </span><span class="mvp-cd-date left relative">1 week ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/11/this-week-on-fox-las-culture-conversations-free-marie-and-rocsi-diaz/">This Week on FOX LA&#8217;s CULTURE CONVERSATIONS: Free Marie and Rocsi Diaz</a></h2>
</div>
</div>
</div>
</div>
</a>
<a href="https://eurweb.com/2020/10/10/cedric-the-entertainer-explains-how-he-got-his-name-on-jalen-roses-podcast-listen/" rel="bookmark">
<div class="mvp-feat1-list-cont left relative">
<div class="mvp-feat1-list-out relative">
<div class="mvp-feat1-list-img left relative">
<img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Cedric-The-Entertainer1.jpg?resize=80%2C80&amp;ssl=1" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="Cedric The Entertainer1" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Cedric-The-Entertainer1.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Cedric-The-Entertainer1.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Cedric-The-Entertainer1.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="863568" data-permalink="https://eurweb.com/2020/10/10/cedric-the-entertainer-explains-how-he-got-his-name-on-jalen-roses-podcast-listen/cedric-the-entertainer1/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Cedric-The-Entertainer1.jpg?fit=575%2C344&amp;ssl=1" data-orig-size="575,344" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cedric The Entertainer1" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Cedric-The-Entertainer1.jpg?fit=300%2C179&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/10/Cedric-The-Entertainer1.jpg?fit=575%2C344&amp;ssl=1" /> </div>
<div class="mvp-feat1-list-in">
<div class="mvp-feat1-list-text">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative"> <a href="https://eurweb.com/category/podcasts/">
Podcasts</a> </span><span class="mvp-cd-date left relative">2 weeks ago</span>
</div>
<h2><a style="color:#222" href="https://eurweb.com/2020/10/10/cedric-the-entertainer-explains-how-he-got-his-name-on-jalen-roses-podcast-listen/">Cedric The Entertainer Explains How He Got His Name on Jalen Rose&#8217;s Podcast / LISTEN</a></h2>
</div>
</div>
</div>
</div>
</a>
</div>
</div>
</div>
</section><section id="search-11" class="mvp-side-widget widget_search"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Search</span></h4></div><form method="get" id="searchform" action="https://eurweb.com/">
<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
<input type="hidden" id="searchsubmit" value="Search" />
</form></section><section id="register_minical_widget-8" class="mvp-side-widget widget_register_minical_widget"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">TV Calendar: Coming to Small Screens</span></h4></div> <div data-tockify-component="upcoming" data-tockify-calendar="screenthirst"></div>
<script type="text/javascript">
        if (window._tkf && window._tkf.loadDeclaredCalendars) {
          window._tkf.loadDeclaredCalendars();
        }
      </script>
</section> </div> </div>
</div>
<div id="mvp-post-more-wrap" class="left relative">
<h4 class="mvp-widget-home-title">
<span class="mvp-widget-home-title">Trending</span>
</h4>
<ul class="mvp-post-more-list left relative">
<a href="https://eurweb.com/2020/06/12/vanessa-bryant-pro-athletes-sliding-in-dms-of-kobe-bryants-widow/" rel="bookmark">
<li>
<div class="mvp-post-more-img left relative">
<img width="400" height="240" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="vanessa bryant, kobe" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?resize=560%2C336&amp;ssl=1 560w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?resize=400%2C240&amp;ssl=1 400w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="816746" data-permalink="https://eurweb.com/2020/01/28/vanessa-bryant-can-hardly-keep-it-together-following-death-of-kobe-daughter-gianna/pjimage-95-2/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?fit=600%2C336&amp;ssl=1" data-orig-size="600,336" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vanessa bryant, kobe" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?fit=600%2C336&amp;ssl=1" /> <img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="vanessa bryant, kobe" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="816746" data-permalink="https://eurweb.com/2020/01/28/vanessa-bryant-can-hardly-keep-it-together-following-death-of-kobe-daughter-gianna/pjimage-95-2/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?fit=600%2C336&amp;ssl=1" data-orig-size="600,336" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vanessa bryant, kobe" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/01/pjimage-95.jpg?fit=600%2C336&amp;ssl=1" /> </div>
<div class="mvp-post-more-text left relative">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">Black Celebrity Gossip - Gossip</span><span class="mvp-cd-date left relative">4 months ago</span>
</div>
<p>Vanessa Bryant: Pro Athletes Sliding in DMs of Kobe Bryant&#8217;s Widow</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/05/07/clutch-my-peaches-cynthia-bailey-reportedly-out-and-offered-reduced-rhoa-role-to-make-room-for-phaedra-parks/" rel="bookmark">
<li>
<div class="mvp-post-more-img left relative">
<img width="400" height="240" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Cynthia Bailey - IG" data-attachment-id="841347" data-permalink="https://eurweb.com/2020/05/07/clutch-my-peaches-cynthia-bailey-reportedly-out-and-offered-reduced-rhoa-role-to-make-room-for-phaedra-parks/cynthia-bailey-ig/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?fit=489%2C535&amp;ssl=1" data-orig-size="489,535" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cynthia Bailey &#8211; IG" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?fit=274%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?fit=489%2C535&amp;ssl=1" /> <img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Cynthia Bailey - IG" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="841347" data-permalink="https://eurweb.com/2020/05/07/clutch-my-peaches-cynthia-bailey-reportedly-out-and-offered-reduced-rhoa-role-to-make-room-for-phaedra-parks/cynthia-bailey-ig/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?fit=489%2C535&amp;ssl=1" data-orig-size="489,535" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cynthia Bailey &#8211; IG" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?fit=274%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/05/Cynthia-Bailey-IG.jpg?fit=489%2C535&amp;ssl=1" /> </div>
<div class="mvp-post-more-text left relative">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">Slider</span><span class="mvp-cd-date left relative">6 months ago</span>
</div>
<p>Clutch My Peaches!: Cynthia Bailey Reportedly Out and Offered Reduced #RHOA Role to Make Room for Phaedra Parks</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/06/05/mike-pence-invites-candace-owens-to-white-house-for-talks-on-race-relations/" rel="bookmark">
<li>
<div class="mvp-post-more-img left relative">
<img width="400" height="240" src="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Candace Owens" data-attachment-id="846009" data-permalink="https://eurweb.com/2020/06/05/ahmaud-arberys-killer-called-him-the-n-word-as-he-lay-dying-video/image009-8-12/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?fit=634%2C321&amp;ssl=1" data-orig-size="634,321" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Candace Owens" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?fit=300%2C152&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?fit=634%2C321&amp;ssl=1" /> <img width="80" height="80" src="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Candace Owens" srcset="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="846009" data-permalink="https://eurweb.com/2020/06/05/ahmaud-arberys-killer-called-him-the-n-word-as-he-lay-dying-video/image009-8-12/" data-orig-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?fit=634%2C321&amp;ssl=1" data-orig-size="634,321" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Candace Owens" data-image-description="" data-medium-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?fit=300%2C152&amp;ssl=1" data-large-file="https://i1.wp.com/eurweb.com/wp-content/uploads/2020/06/image009-8-e1591360058204.jpg?fit=634%2C321&amp;ssl=1" /> </div>
<div class="mvp-post-more-text left relative">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">Black Celebrity Gossip - Gossip</span><span class="mvp-cd-date left relative">5 months ago</span>
</div>
<p>Mike Pence Invites Candace Owens to White House for Talks on Race Relations</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/05/13/trapped-in-the-closet-fans-suspect-diddys-new-girlfriend-is-transgender-video/" rel="bookmark">
<li>
<div class="mvp-post-more-img left relative">
<img width="400" height="240" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Sean ‘Diddy’ Combs" data-attachment-id="826797" data-permalink="https://eurweb.com/2020/03/31/sean-diddy-combs-debuts-grey-hair-and-beard-in-his-covid-19-psa-video-watch/euzh9sxuyae0dv4/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?fit=620%2C349&amp;ssl=1" data-orig-size="620,349" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Sean ‘Diddy’ Combs" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?fit=620%2C349&amp;ssl=1" /> <img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Sean ‘Diddy’ Combs" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="826797" data-permalink="https://eurweb.com/2020/03/31/sean-diddy-combs-debuts-grey-hair-and-beard-in-his-covid-19-psa-video-watch/euzh9sxuyae0dv4/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?fit=620%2C349&amp;ssl=1" data-orig-size="620,349" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Sean ‘Diddy’ Combs" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/03/EUZH9sxUYAE0DV4.jpg?fit=620%2C349&amp;ssl=1" /> </div>
<div class="mvp-post-more-text left relative">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">Black Celebrity Gossip - Gossip</span><span class="mvp-cd-date left relative">5 months ago</span>
</div>
<p>Trapped in the Closet? Fans Suspect Diddy&#8217;s New Girlfriend is Transgender [VIDEO]</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/05/29/jacob-pederson-minneapolis-police-officer-accused-of-starting-minneapolis-riot-watch/" rel="bookmark">
<li>
<div class="mvp-post-more-img left relative">
<img width="400" height="240" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Officer Jacob Pederson" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?resize=560%2C336&amp;ssl=1 560w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?resize=400%2C240&amp;ssl=1 400w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="844817" data-permalink="https://eurweb.com/2020/05/29/jacob-pederson-minneapolis-police-officer-accused-of-starting-minneapolis-riot-watch/pjimage-2020-05-29t074238-864/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?fit=600%2C336&amp;ssl=1" data-orig-size="600,336" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Officer Jacob Pederson" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?fit=600%2C336&amp;ssl=1" /> <img width="80" height="80" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Officer Jacob Pederson" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="844817" data-permalink="https://eurweb.com/2020/05/29/jacob-pederson-minneapolis-police-officer-accused-of-starting-minneapolis-riot-watch/pjimage-2020-05-29t074238-864/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?fit=600%2C336&amp;ssl=1" data-orig-size="600,336" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Officer Jacob Pederson" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/05/pjimage-2020-05-29T074238.864.jpg?fit=600%2C336&amp;ssl=1" /> </div>
<div class="mvp-post-more-text left relative">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">George Floyd</span><span class="mvp-cd-date left relative">5 months ago</span>
</div>
<p>Jacob Pederson: St. Paul Police Officer Accused of Starting #GeorgeFloyd Riot [WATCH]</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/06/15/black-stabbing-candace-owens-raising-funds-for-cop-who-killed-rayshard-brooks-wants-atl-mayor-fired/" rel="bookmark">
<li>
<div class="mvp-post-more-img left relative">
<img width="400" height="240" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Brooks owens Rolfe" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?resize=590%2C354&amp;ssl=1 590w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?resize=400%2C240&amp;ssl=1 400w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="847528" data-permalink="https://eurweb.com/2020/06/15/black-stabbing-candace-owens-raising-funds-for-cop-who-killed-rayshard-brooks-wants-atl-mayor-fired/brooks-owens-rolfe/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?fit=659%2C380&amp;ssl=1" data-orig-size="659,380" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Brooks owens Rolfe" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?fit=300%2C173&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?fit=659%2C380&amp;ssl=1" /> <img width="80" height="80" src="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Brooks owens Rolfe" srcset="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="847528" data-permalink="https://eurweb.com/2020/06/15/black-stabbing-candace-owens-raising-funds-for-cop-who-killed-rayshard-brooks-wants-atl-mayor-fired/brooks-owens-rolfe/" data-orig-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?fit=659%2C380&amp;ssl=1" data-orig-size="659,380" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Brooks owens Rolfe" data-image-description="" data-medium-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?fit=300%2C173&amp;ssl=1" data-large-file="https://i2.wp.com/eurweb.com/wp-content/uploads/2020/06/Brooks-owens-Rolfe.jpg?fit=659%2C380&amp;ssl=1" /> </div>
<div class="mvp-post-more-text left relative">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">#BlackLivesMatter</span><span class="mvp-cd-date left relative">4 months ago</span>
</div>
<p>B(l)ack Stabbing Candace Owens Raising Funds for Cop who Killed Rayshard Brooks &#8211; Wants ATL Mayor Fired</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/06/27/ms-robbie-of-welcome-to-sweetie-pies-claims-sons-ex-wont-allow-her-to-see-grandson-video/" rel="bookmark">
<li>
<div class="mvp-post-more-img left relative">
<img width="400" height="240" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Miss Robbie &amp; grandson1" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?resize=300%2C181&amp;ssl=1 300w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?resize=590%2C354&amp;ssl=1 590w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?resize=400%2C240&amp;ssl=1 400w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="849227" data-permalink="https://eurweb.com/2020/06/27/ms-robbie-of-welcome-to-sweetie-pies-claims-sons-ex-wont-allow-her-to-see-grandson-video/miss-robbie-grandson1/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?fit=657%2C397&amp;ssl=1" data-orig-size="657,397" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Miss Robbie &#038; grandson1" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?fit=300%2C181&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?fit=657%2C397&amp;ssl=1" /> <img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Miss Robbie &amp; grandson1" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="849227" data-permalink="https://eurweb.com/2020/06/27/ms-robbie-of-welcome-to-sweetie-pies-claims-sons-ex-wont-allow-her-to-see-grandson-video/miss-robbie-grandson1/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?fit=657%2C397&amp;ssl=1" data-orig-size="657,397" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Miss Robbie &#038; grandson1" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?fit=300%2C181&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/Miss-Robbie-grandson1.jpg?fit=657%2C397&amp;ssl=1" /> </div>
<div class="mvp-post-more-text left relative">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">News</span><span class="mvp-cd-date left relative">4 months ago</span>
</div>
<p>Ms. Robbie of &#8216;Welcome to Sweetie Pies&#8217; Claims Son’s Ex Won’t Allow Her to See Grandson [VIDEO]</p>
</div>
</li>
</a>
<a href="https://eurweb.com/2020/06/02/granddaughter-of-joe-jackson-stabbed-in-racially-charged-attack-photos/" rel="bookmark">
<li>
<div class="mvp-post-more-img left relative">
<img width="400" height="240" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?resize=400%2C240&amp;ssl=1" class="mvp-reg-img wp-post-image" alt="Joe Jackson’s granddaughter Yasmine" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?resize=590%2C354&amp;ssl=1 590w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?resize=400%2C240&amp;ssl=1 400w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="845392" data-permalink="https://eurweb.com/2020/06/02/minnesota-police-respond-to-viral-clip-showing-arrest-of-fbi-agent-video/image001-56-5/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?fit=618%2C356&amp;ssl=1" data-orig-size="618,356" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Joe Jackson’s granddaughter Yasmine" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?fit=300%2C173&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?fit=618%2C356&amp;ssl=1" /> <img width="80" height="80" src="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?resize=80%2C80&amp;ssl=1" class="mvp-mob-img wp-post-image" alt="Joe Jackson’s granddaughter Yasmine" srcset="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="845392" data-permalink="https://eurweb.com/2020/06/02/minnesota-police-respond-to-viral-clip-showing-arrest-of-fbi-agent-video/image001-56-5/" data-orig-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?fit=618%2C356&amp;ssl=1" data-orig-size="618,356" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Joe Jackson’s granddaughter Yasmine" data-image-description="" data-medium-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?fit=300%2C173&amp;ssl=1" data-large-file="https://i0.wp.com/eurweb.com/wp-content/uploads/2020/06/image001-56-e1591112679786.jpg?fit=618%2C356&amp;ssl=1" /> </div>
<div class="mvp-post-more-text left relative">
<div class="mvp-cat-date-wrap left relative">
<span class="mvp-cd-cat left relative">Black Celebrity Gossip - Gossip</span><span class="mvp-cd-date left relative">5 months ago</span>
</div>
<p>Yasmine Jackson: Granddaughter of Joe Jackson Stabbed in Racially Charged Attack [PHOTOS]</p>
</div>
</li>
</a>
</ul>
</div>
</div>
</div>
</article>
</div>
<footer id="mvp-foot-wrap" class="left relative">
<div id="mvp-foot-top" class="left relative">
<div class="mvp-main-box">
<div id="mvp-foot-logo" class="left relative">
<a href="https://eurweb.com/"><img src="https://eurweb.com/wp-content/uploads/2020/03/eurwebwhite.png" alt="EURweb" data-rjs="2" /></a>
</div>
<div id="mvp-foot-soc" class="left relative">
<ul class="mvp-foot-soc-list left relative">
<li><a href="https://www.facebook.com/EURweb/" target="_blank" class="fa fa-facebook fa-2"></a></li>
<li><a href="https://twitter.com/eurweb" target="_blank" class="fa fa-twitter fa-2"></a></li>
<li><a href="https://www.instagram.com/eurweb" target="_blank" class="fa fa-instagram fa-2"></a></li>
</ul>
</div>
<div id="mvp-foot-menu-wrap" class="left relative">
<div id="mvp-foot-menu" class="left relative">
<div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="menu"><li id="menu-item-129624" class="menu-item menu-item-type- menu-item-object- menu-item-129624"><a></a></li>
<li id="menu-item-129628" class="menu-item menu-item-type- menu-item-object- menu-item-129628"><a></a></li>
<li id="menu-item-469483" class="menu-item menu-item-type- menu-item-object- menu-item-469483"><a></a></li>
<li id="menu-item-129625" class="menu-item menu-item-type- menu-item-object- menu-item-129625"><a></a></li>
<li id="menu-item-703694" class="menu-item menu-item-type- menu-item-object- menu-item-703694"><a></a></li>
<li id="menu-item-129626" class="menu-item menu-item-type- menu-item-object- menu-item-129626"><a></a></li>
<li id="menu-item-129627" class="menu-item menu-item-type- menu-item-object- menu-item-129627"><a></a></li>
<li id="menu-item-346041" class="menu-item menu-item-type- menu-item-object- menu-item-346041"><a></a></li>
<li id="menu-item-729122" class="menu-item menu-item-type- menu-item-object- menu-item-729122"><a></a></li>
</ul></div> </div>
</div>
</div>
</div>
<div id="mvp-foot-bot" class="left relative">
<div class="mvp-main-box">
<div id="mvp-foot-copy" class="left relative">
<p>WHO WE ARE<br>
The news you want – unfiltered.<br> The Electronic Urban Report/EUR puts the most buzz worthy African American news at your fingertips. There is no more complete source for urban news than the Electronic Urban Report.
COPYRIGHT 2020 EURweb.com/Rabercom Enterprises</p>
</div>
</div>
</div>
</footer>
</div>
</div>
</div>
<div class="mvp-fly-top back-to-top">
<i class="fa fa-angle-up fa-3"></i>
</div>
<div class="mvp-fly-fade mvp-fly-but-click">
</div>
<div style="display:none">
<div class="grofile-hash-map-75d389737dd4bc2e54cf0d5fcc866431">
</div>
<div class="grofile-hash-map-54a26a30774aaab0b505ea0e1d14eecf">
</div>
</div>
<script type='application/ld+json'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://eurweb.com/#website","url":"https://eurweb.com/","name":"EURweb","potentialAction":{"@id":"https://eurweb.com/2020/10/21/865561#searchaction"},"publisher":{"@id":"https://eurweb.com/#organization"}},{"@type":"SearchAction","@id":"https://eurweb.com/2020/10/21/865561#searchaction","target":"https://eurweb.com/?s={search_term_string}","query-input":"required name=search_term_string"},{"@type":"BreadcrumbList","@id":"https://eurweb.com/2020/10/21/865561#breadcrumbs","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://eurweb.com/"},{"@type":"ListItem","position":2,"name":"News","item":"https://eurweb.com/category/news-2/"},{"@type":"ListItem","position":3,"name":"#BlackLivesMatter","item":"https://eurweb.com/category/news-2/blacklivesmatter/"}]},{"@type":"WebPage","@id":"https://eurweb.com/2020/10/21/865561#webpage","url":"https://eurweb.com/2020/10/21/865561","inLanguage":"en_US","name":"Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria &#8211; EURweb","description":"“The ability for citizens to demonstrate safely when they see injustice within their government should be a sacred right across the globe.\" - Ben Crump","datePublished":"2020-10-22T01:03:15+00:00","dateModified":"2020-10-22T01:27:48+00:00","isPartOf":{"@id":"https://eurweb.com/#website"},"breadcrumb":{"@id":"https://eurweb.com/2020/10/21/865561#breadcrumbs"},"primaryImageOfPage":{"@id":"https://eurweb.com/2020/10/21/865561#thumbnail"},"image":{"@id":"https://eurweb.com/2020/10/21/865561#thumbnail"}},{"@type":"Organization","@id":"https://eurweb.com/#organization","url":"https://eurweb.com/","name":"EURweb","logo":{"@id":"https://eurweb.com/2020/10/21/865561#logo"},"image":{"@id":"https://eurweb.com/2020/10/21/865561#logo"}},{"@type":"ImageObject","@id":"https://eurweb.com/2020/10/21/865561#logo","url":"https://eurweb.com/wp-content/uploads/2020/04/favicon.ico","width":16,"height":16},{"@type":"ImageObject","@id":"https://eurweb.com/2020/10/21/865561#thumbnail","url":"https://i1.wp.com/eurweb.com/wp-content/uploads/2020/10/Nigeria-anti-police-protests.jpg?fit=650%2C286&ssl=1","width":650,"height":286},{"@type":"Article","@id":"https://eurweb.com/2020/10/21/865561#article","url":"https://eurweb.com/2020/10/21/865561","headline":"Attorney Ben Crump Issues Statement About Police Violence Against Protestors in Lagos Nigeria","datePublished":"2020-10-22T01:03:15+00:00","dateModified":"2020-10-22T01:27:48+00:00","wordCount":216,"keywords":["ben crump","nigeria anti-police brutality protest"],"articleSection":["#BlackLivesMatter","Police - Police Abuse","Urban News"],"isPartOf":{"@id":"https://eurweb.com/2020/10/21/865561#webpage"},"mainEntityOfPage":{"@id":"https://eurweb.com/2020/10/21/865561#webpage"},"image":{"@id":"https://eurweb.com/2020/10/21/865561#thumbnail"},"publisher":{"@id":"https://eurweb.com/#organization"},"author":{"@id":"https://eurweb.com/2020/10/21/865561#author"}},{"@type":"Person","@id":"https://eurweb.com/2020/10/21/865561#author","url":"https://eurweb.com/author/rabercom/","name":"Fisher Jack","givenName":"Lee","familyName":"Bailey","image":{"@id":"https://eurweb.com/2020/10/21/865561#author_image"}},{"@type":"ImageObject","@id":"https://eurweb.com/2020/10/21/865561#author_image","url":"https://secure.gravatar.com/avatar/75d389737dd4bc2e54cf0d5fcc866431?s=96&d=mm&r=g","width":96,"height":96,"caption":"Fisher Jack"}]}</script>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/eurweb.com\/2020\/10\/21\/865561\/":865561,"https:\/\/eurweb.com\/2020\/10\/21\/ohio-business-owner-says-his-white-lives-matter-who-else-will-pay-for-welfare-sign-is-not-racist-watch\/":865456,"https:\/\/eurweb.com\/2020\/10\/21\/this-is-not-kneeling-on-a-neck-cop-shot-during-breonna-taylor-raid-says-it-was-not-a-race-thing-watch\/":865452,"https:\/\/eurweb.com\/2020\/10\/21\/white-woman-yells-f-black-lives-matter-to-starbucks-barista-during-mask-rant-watch\/":865425};
	</script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/p/jetpack/8.9.1/_inc/build/photon/photon.min-60794cc24e2de8ac6eac05da1bb13dd6.js'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/wp-content/plugins/fitvids-for-wordpress/jquery.fitvids-23d35d8cb2e766af5a4da0b14e80c7a7.js'></script>
<script type='text/javascript' src='https://eurweb.com/wp-content/plugins/simple-posts-ticker/public/js/jquery.marquee.min.js?ver=1.5.0'></script>
<script type='text/javascript' src='https://eurweb.com/wp-content/plugins/simple-posts-ticker/public/js/ticker.min.js?ver=1.1.5'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/browser/embed-a9c853d6362a1fe8ddfb99184dafcff3.js'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/c/5.4.2/wp-includes/js/jquery/ui/core.min-4adee1151a22dc90e1935253c4dcc88c.js'></script>
<script type='text/javascript' src='https://eurweb.com/wp-content/plugins/zox-alp//scripts/jquery.sticky-kit.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://eurweb.com/wp-content/plugins/zox-alp//scripts/jquery.waypoints.min.js?ver=5.4.2'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/wp-content/plugins/marfeelpress/includes/base/src/resources/js/resizer-cf5c85d1ee9f8b5d6ab1e0656ced41e9.js'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/js/gprofiles-44a5314d80194b469d00aa30d61fbc6e.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/p/jetpack/8.9.1/modules/wpgroho-78454232e3ae05646bdad0eaf5992e01.js'></script>
<script type='text/javascript' src='https://eurweb.com/wp-content/themes/zox-news/js/mvpcustom.js?ver=5.4.2'></script>
<script type='text/javascript'>
	jQuery(document).ready(function($) {
	$(window).load(function(){
	var leaderHeight = $("#mvp-leader-wrap").outerHeight();
	var logoHeight = $("#mvp-main-nav-top").outerHeight();
	var botHeight = $("#mvp-main-nav-bot").outerHeight();
	var navHeight = $("#mvp-main-head-wrap").outerHeight();
	var headerHeight = navHeight + leaderHeight;
	var aboveNav = leaderHeight + logoHeight;
	var totalHeight = logoHeight + botHeight;
	var previousScroll = 0;
	$(window).scroll(function(event){
			var scroll = $(this).scrollTop();
			if ($(window).scrollTop() > aboveNav){
				$("#mvp-main-nav-top").addClass("mvp-nav-small");
				$("#mvp-main-nav-bot").css("margin-top", logoHeight );
			} else {
				$("#mvp-main-nav-top").removeClass("mvp-nav-small");
				$("#mvp-main-nav-bot").css("margin-top","0");
			}
			if ($(window).scrollTop() > headerHeight){
				$("#mvp-main-nav-top").addClass("mvp-fixed");
				$("#mvp-main-nav-bot").addClass("mvp-fixed1");
				$("#mvp-main-body-wrap").css("margin-top", totalHeight );
				$("#mvp-main-nav-top").addClass("mvp-fixed-shadow");
				$(".mvp-nav-top-mid").addClass("mvp-fixed-post");
				$(".mvp-drop-nav-title").show();
				$(".mvp-fly-top").addClass("mvp-to-top");
	    		if(scroll < previousScroll) {
					$("#mvp-main-nav-bot").addClass("mvp-fixed2");
					$("#mvp-main-nav-top").removeClass("mvp-fixed-shadow");
					$("#mvp-main-nav-top").removeClass("mvp-soc-mob-up");
					$("#mvp-soc-mob-wrap").removeClass("mvp-soc-mob-up");
				} else {
					$("#mvp-main-nav-bot").removeClass("mvp-fixed2");
					$("#mvp-main-nav-top").addClass("mvp-fixed-shadow");
					$("#mvp-main-nav-top").addClass("mvp-soc-mob-up");
					$("#mvp-soc-mob-wrap").addClass("mvp-soc-mob-up");
				}
			} else {
				$("#mvp-main-nav-top").removeClass("mvp-fixed");
				$("#mvp-main-nav-bot").removeClass("mvp-fixed1");
				$("#mvp-main-nav-bot").removeClass("mvp-fixed2");
				$("#mvp-main-body-wrap").css("margin-top","0");
				$("#mvp-main-nav-top").removeClass("mvp-fixed-shadow");
				$(".mvp-nav-top-mid").removeClass("mvp-fixed-post");
				$(".mvp-drop-nav-title").hide();
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
			}
			previousScroll = scroll;
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Video Post Scroll
	$(window).on("scroll.video", function(event){
		var scrollTop     = $(window).scrollTop();
    	var elementOffset = $("#mvp-content-wrap").offset().top;
    	var distance      = (elementOffset - scrollTop);
		var aboveHeight = $("#mvp-video-embed-wrap").outerHeight();
		if ($(window).scrollTop() > distance + aboveHeight + screen.height){
			$("#mvp-video-embed-cont").addClass("mvp-vid-fixed");
			$("#mvp-video-embed-wrap").addClass("mvp-vid-height");
			$(".mvp-video-close").show();
		} else {
			$("#mvp-video-embed-cont").removeClass("mvp-vid-fixed");
			$("#mvp-video-embed-wrap").removeClass("mvp-vid-height");
			$(".mvp-video-close").hide();
		}
	});

 	$(".mvp-video-close").on("click", function(){
		$("iframe").attr("src", $("iframe").attr("src"));
		$("#mvp-video-embed-cont").removeClass("mvp-vid-fixed");
		$("#mvp-video-embed-wrap").removeClass("mvp-vid-height");
		$(".mvp-video-close").hide();
		$(window).off("scroll.video");
  	});

	});
  	

	jQuery(document).ready(function($) {
	// Mobile Social Buttons More
	$(window).load(function(){
 		$(".mvp-soc-mob-right").on("click", function(){
			$("#mvp-soc-mob-wrap").toggleClass("mvp-soc-mob-more");
  		});
  	});
	});
  	

	jQuery(document).ready(function($) {
	$(".menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  
  	});

	$(".menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});
	
</script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/wp-content/themes/zox-news/js/scripts-f4c40e7858c08f437706b76a6e716add.js'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/wp-content/themes/zox-news/js/retina-050603a858cb23217155439d507e0960.js'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/wp-content/themes/zox-news/js/flexslider-230e524a2e451d98bf6ff2b06fcac4be.js'></script>
<script type='text/javascript' src='https://eurweb.com/wp-content/themes/zox-news/js/jquery.infinitescroll.min.js?ver=5.4.2'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/c/5.4.2/wp-includes/js/comment-reply.min-61409d90a7d442417c79536c621a35f4.js'></script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/c/5.4.2/wp-includes/js/wp-embed.min-10415524b6f3c7c6adf5ffa025873b82.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/eurweb.com\/wp-admin\/admin-ajax.php","nonce":"c282858c7e","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/eurweb.com\/wp-login.php?redirect_to=https%3A%2F%2Feurweb.com%2F2020%2F10%2F21%2F865561%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/p/jetpack/8.9.1/_inc/build/carousel/jetpack-carousel.min-9ec2972aab8f0c7b5d9856f7d2df9bb4.js'></script>
<script data-minify="1" async="async" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/wp-content/plugins/akismet/_inc/form-5769f4247c8c69ab1124cdb92876105d.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://eurweb.com/wp-content/cache/min/1/p/jetpack/8.9.1/_inc/build/sharedaddy/sharing.min-02d0ecb741e00ca33969d4f6506ff273.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
<script type="text/javascript">
		jQuery(document).ready(function () {
			jQuery('body').fitVids();
		});
		</script> <script type="text/javascript">
	     	jQuery('.soliloquy-container').removeClass('no-js');
	   </script>
<script type='text/javascript' src='https://stats.wp.com/e-202043.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'45208910',post:'865561',tz:'-7',srv:'eurweb.com'} ]);
	_stq.push([ 'clickTrackerInit', '45208910', '865561' ]);
</script>
<style>
	.mvp-cat-date-wrap { margin-bottom:3px !important; } 
	#mvp-feat3-wrap h2 { width:100% !important; float:left !important; }
.home .mvp-widget-dark-right h2 a , .home  h2.mvp-stand-title  a , .mvp-widget-dark-main h2 a ,   .ff2{ color:#fff !important; text-decoration:none; }
.home .mvp-cd-date { float:right !important; }
.home .mvp-cat-date-wrap { width:auto !important;  }
.home .mvp-cat-date-wrap a
{
         color: #dd4726 !important;
    font-size: 11.2px !important;
    position: relative;
    top: -4px;
    text-transform: uppercase;
    font-weight: 700;
}
.top-link-2 , .top-link{    position: absolute;
    left: 0;
    top: 0;
    height: 100%;
    width: 100%;
    cursor: pointer;
    z-index: 9;}
    .tt6 , .tt20 , .ff6 { color:#222 !important; }
    .ff2 { color:#fff !important; }
    @media(min-width:1024px) {
       .home  .mvp-widget-feat1-top-story {
    margin-left: 1.66666666%;
    overflow: hidden;
    width: 48%;
}
.home .mvp-widget-feat1-bot-story {
    margin-left: 1.66666666%;
    width: 23.2%;
}
        }
</style>
</body>
</html>

